HDU 1083 Courses(匈牙利模板)

Courses

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11557    Accepted Submission(s): 5408

 

Problem Description

Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:

. every student in the committee represents a different course (a student can represent a course if he/she visits that course)

. each course has a representative in the committee

Your program should read sets of data from a text file. The first line of the input file contains the number of the data sets. Each data set is presented in the following format:

P N
Count1 Student1 1 Student1 2 ... Student1 Count1
Count2 Student2 1 Student2 2 ... Student2 Count2
...... 
CountP StudentP 1 StudentP 2 ... StudentP CountP

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses . from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you'll find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.

There are no blank lines between consecutive sets of data. Input data are correct.

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

An example of program input and output:

 

Sample Input

2 3 3

3 1 2 3

2 1 2

1 1

3 3 2

1 3

2 1 3

1 1

Sample Output

YES

NO

Source

Southeastern Europe 2000

题意:
有p门课,n个学生。

 要为每门课都分配一个课代表。

如果每门课都能找到一个课代表,则YES,否则NO

#include <iostream>
#include <algorithm>
#include <string>
#include <cstring>
#include <cstdio>
#include <stack>
#include <queue>
#define ll long long
#define Max 400
using namespace std;
int l,r;//左边点,和右边点 
int ln,rn;//个数 
int used[Max];//记录右边的点是否完成配对 
int from[Max];//记录右边的点谁跟他配对
int to[Max][Max];//左边到右边的连线
int dfs(int L)
{
	for(int rr=1;rr<=rn;rr++)//右边 
	{
		if(to[L][rr]&&!used[rr])
		{
			used[rr]=1;
			if(from[rr]==-1||dfs(from[rr]))
			{
				from[rr]=L;
				return 1;
			}
		}
	}
	return 0;
}
int hungry()
{
	int ans=0;
	memset(from,-1,sizeof(from));
	for(int i=1;i<=ln;i++)//左边 
	{
		memset(used,0,sizeof(used));
		if(dfs(i))
			ans++; 
	}
	return ans;
}
int main()
{
	int t,p,n;
	cin>>t;
	while(t--)
	{
		cin>>p>>n;
		memset(to,0,sizeof(to));
		for(int i=1;i<=p;i++)
		{
			int k;
			cin>>k;
			for(int j=1;j<=k;j++)
			{
				cin>>r;
				l=i;
				to[l][r]=1;
			}
		}
		ln=p;
		rn=n;
		int ans=hungry();
//		cout<<ans<<endl;
		if(ans==ln)
		{
			cout<<"YES"<<endl;
		 } else cout<<"NO"<<endl;
	}
	return 0;
	
 } 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值