HDU 1024 Max Sum Plus Plus(动态规划+m子段和的最大值)

Max Sum Plus Plus

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 39787    Accepted Submission(s): 14307

 

Problem Description

Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S1, S2, S3, S4 ... Sx, ... Sn (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ Sx ≤ 32767). We define a function sum(i, j) = Si + ... + Sj (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i1, j1) + sum(i2, j2) + sum(i3, j3) + ... + sum(im, jm) maximal (ix ≤ iy ≤ jx or ix ≤ jy ≤ jx is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(ix, jx)(1 ≤ x ≤ m) instead. ^_^

Input

Each test case will begin with two integers m and n, followed by n integers S1, S2, S3 ... Sn.
Process to the end of file.

Output

Output the maximal summation described above in one line.

 

Sample Input

1 3 1 2 3

2 6 -1 4 -2 3 -2 3 

 

Sample Output

6

8

Hint

Huge input, scanf and dynamic programming is recommended.

题意:输入一个m,n   即将n个数分成m组,m组的和加起来得到最大值并输出。

dp[i][j]表示前j个数分成i组的最大值。

dp[i][j]=max(dp[i][j-1]+a[j],max(dp[i-1][k])+a[j]) (0<k<j)

dp[i][j-1]+a[j]表示的是前j-1分成i组,第j个必须放在前一组里面。

max( dp[i-1][k] ) + a[j] )表示的前(0<k<j)分成i-1组,第j个单独分成一组。

max( dp[i-1][k] ) 就是上一组 0....j-1 的最大值。我们可以在每次计算dp[i][j]的时候记录下前j个
的最大值 用数组保存下来 

 

#include <iostream>
#include <cstring>
#include <string>
#include <algorithm>
#include <vector>
#include <map>
#include <stack>
#include <queue>
#include <iomanip>
#define ll long long
#define inf 0x3f3f3f3f
#define Maxx 1000002
using namespace std;
int a[Maxx],n,m;
int dp[Maxx];
int Max[Maxx];//max(dp[i-1][k]) 就是上一组0~j-1的最大值
int main()
{
	while(scanf("%d%d",&m,&n)!=EOF)
	{
		int mmax;
		for(int i=1;i<=n;i++)
			scanf("%d",&a[i]);
		memset(dp,0,sizeof(dp));
		memset(Max,0,sizeof(Max));
		for(int i=1;i<=m;i++)//分成i组 
		{
			mmax=-inf;
			for(int j=i;j<=n;j++)//前j个数分成i组,至少需要i个数 
			{
				dp[j]=max(dp[j-1]+a[j],Max[j-1]+a[j]);
			//Max[j-1]目前代表的是分成i-1组前j-1个数的最大值,a[j]单独一组组成i组
			//dp[j-1]代表j-1个数分成组,第j个数a[j]放在前面i组的一组中,两种方式选取较大者 
				Max[j-1]=mmax;//当前考虑的是j但是mmax是上一次循环得到的,所以更新的是j-1 
				mmax=max(mmax,dp[j]);//更新mmax,这样下次循环同样更新的是j-1 
			}
			//这样也就更新得到了 分i组的 Max,下次分i+1组的时候就可以使用了 
		}printf("%d\n",mmax); 
	}
	return 0;
 } 

 

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值