D:Radar Installation

D:Radar Installation

总时间限制: 

1000ms

 

内存限制: 

65536kB

描述

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.


Figure A Sample Input of Radar Installations

输入

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

输出

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

样例输入

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

样例输出

Case 1: 2
Case 2: 1

来源

Beijing 2002

解题思路:

将每个岛屿通过勾股定理投影到海岸线x轴上,投影得一直线,直线范围内只要有一个雷达就表示此岛屿在雷达范围内,于是问题转换成有多组线段在x轴上,寻求一个最少的雷达数量能让所有线段内部都有雷达。非常典型的贪心法

#include<bits/stdc++.h>

using namespace std;

bool cmp(pair<double,double> a,pair<double,double> b)
{
    return a.second<b.second;
}

int main()
{
    //freopen("in.txt","r",stdin);
    int n;
    double d;
    int po=1;
    bool f;
    while(scanf("%d %lf", &n, &d)&&(n||d))
    {
        f=true;
        double x,y;
        vector<pair<double,double> > vec;
        for(int i=0;i<n;i++)
        {	
            scanf("%lf %lf", &x, &y);
            if(!f) continue;
            double dx;
            dx=d*d-y*y;
            if(y<=d)
            	vec.push_back(pair<double,double>(x-sqrt(dx),x+sqrt(dx)));
            else
            {
            	f=false;
            }
        }
        printf("Case %d: ",po++);
        if(!f)
        {
        	printf("-1\n");
        	continue;
        }
        sort(vec.begin(),vec.end(),cmp);
        int k=0;
		double temp=-100000000;
        for(int i=0;i<n;i++)
        {
            if(temp<vec[i].first)
            {
                k++;
                temp=vec[i].second;
            }
        }
        printf("%d\n",k);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值