Give you a sequence of N(N≤100,000) integers : a1,…,an(0<ai≤1000,000,000). There are Q(Q≤100,000) queries. For each query l,r you have to calculate gcd(al,al+1,…,ar) and count the number of pairs(l′,r′)(1≤l<r≤N)such that gcd(al′,al′+1,…,ar′) equal gcd(al,al+1,…,ar).
Input
The first line of input contains a number T, which stands for the number of test cases you need to solve.
The first line of each case contains a number N, denoting the number of integers.
The second line contains N integers, a1,…,an(0<ai≤1000,000,000).
The third line contains a number Q, denoting the number of queries.
For the next Q lines, i-th line contains two number , stand for the li,ri, stand for the i-th queries.
Output
For each case, you need to output “Case #:t” at the beginning.(with quotes, t means the number of the test case, begin from 1).
For each query, you need to output the two numbers in a line. The first number stands for gcd(al,al+1,…,ar) and the second number stands for the number of pairs(l′,r′) such that gcd(al′,al′+1,…,ar′) equal gcd(al,al+1,…,ar).
Sample Input
1
5
1 2 4 6 7
4
1 5
2 4
3 4
4 4
Sample Output
Case #1:
1 8
2 4
2 4
6 1
区间 GCD 的问题;
用 ST 表预处理,然后二分区间处理每个 GCD有多少个即可;
用 map 映射即可;
#include<iostream>
#include<cstdio>
#include<map>
#include<algorithm>
#include<cstring>
#include<string>
using namespace std;
#define maxn 2000005
typedef long long ll;
#define inf 0x3f3f3f3f
inline int read()
{
int x = 0, k = 1; char c = getchar();
while (c < '0' || c > '9') { if (c == '-')k = -1; c = getchar(); }
while (c >= '0' && c <= '9')x = (x << 3) + (x << 1) + (c ^ 48), c = getchar();
return x * k;
}
ll gcd(ll a,ll b)
{
return b==0?a:gcd(b,a%b);
}
ll a[maxn];
ll dp[maxn][21];
map<ll,ll>mp;
int init(int n)
{
for(int i=0;i<n;i++)dp[i][0]=a[i];
for(int j=1;(1<<j)<=n;j++){
for(int i=0;i+(1<<j)-1<n;i++){
dp[i][j]=gcd(dp[i][j-1],dp[i+(1<<(j-1))][j-1]);
}
}
}
ll getGcd(int l,int r)
{
int k=0;
while((r-l+1)>=(1<<(k+1)))k++;
return gcd(dp[l][k],dp[r-(1<<k)+1][k]);
}
int main()
{
int n,q,l,m,t,r;
t=read();int cnt=0;
while(t--){
cnt++;
n=read();
for(int i=0;i<n;i++){
//a[i]=read();
scanf("%lld",&a[i]);
}
init(n);
mp.clear();
for(int i=0;i<n;i++){
int j=i;
while(j<n){
int ggcd=getGcd(i,j);
l=j;r=n-1;
while(l<r){
int mid=(l+r+1)>>1;
if(ggcd>getGcd(i,mid))r=mid-1;
else l=mid;
}
mp[ggcd]+=l-j+1;j=l+1;
}
}
q=read();
cout<<"Case #"<<cnt<<":"<<endl;
while(q--){
l=read();r=read();
l--;r--;
int ggcd=getGcd(l,r);
cout<<ggcd<<' '<<mp[ggcd]<<endl;
}
}
}