A1023 Have Fun with Numbers

 

A1023 Have Fun with Numbers

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with kdigits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

注意要点:

  • 判断下一位的进位时,上一位已经改变,所以必须使用temp来操作上一位,而且要用一个flag来保存进位的信息
  • 本题乘以2之后只会在0-19之间,所以直接减10就行
  • 比对是否是相同数字排列的技巧:book[10]记录每个数字出现次数,全部为0说明刚好对应上
  • 记得给flag初始化,提交能通过……但是dev和vs里面过不了……
#include <iostream>
using namespace std;
int main(){
  string s;
  cin >> s;
  int len = s.length();
  int a[len];
  for(int i = 0; i < len; i++){
    a[i] = s[i] - '0';
  }
  int flag = 0;
  int book[10] = {0};
  for(int i = len - 1; i >= 0; i--){
    int temp = a[i];
    book[temp]++;
    temp = temp * 2 + flag;
    flag = 0;         //每次先要重置进位的标志
    if(temp >= 10){
      temp = temp - 10;
      flag = 1;     //下一位进位的标志
    }
    a[i] = temp;    //乘以2之后的数字
    book[temp]--;
  }
  int flag1 = 0;
  for(int i = 0; i < 10; i++){
    if(book[i] != 0)
      flag1 = 1;
  }
  if(flag == 1 || flag1 == 1)
    cout << "No" << endl;
  else
    cout << "Yes" << endl;
  if(flag == 1)
    cout << "1";
  for(int i = 0; i < len; i++){
    cout << a[i];
  }
  return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值