7-3 树的遍历 (25分)

给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。

输入格式:
输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。

输出格式:
在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
输出样例:
4 1 6 3 5 7 2

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;

template <class DataType>
struct BiNode
{
 	DataType data;
  	BiNode<DataType> *lchild, *rchild;
  	BiNode(DataType n){
        data=n;
        lchild=NULL;
        rchild=NULL;
  	}
};

template <class DataType>
class BiTree
{
public:
    BiTree()
    {
        int n,i;
        cin>>n;
        int *h,*z;
        h=new int[n];
        z=new int[n];
        for(i=0; i<n; i++)
        {
            cin>>h[i];
        }
        for(i=0; i<n; i++)
        {
            cin>>z[i];
        }
        root = Creat(h,z,n);
    }
  	void LeverOrder();                     //层序遍历二叉树
private:
  	BiNode<DataType> *Creat(DataType *h,DataType *z,int n);       //构造函数调用
    BiNode<DataType> *root;                             //指向根结点的头指针
};

template <class DataType>
BiNode<DataType> *BiTree<DataType> ::Creat(DataType *h,DataType *z,int n){
    if(n==0)
        return NULL;
    int k=0;
    while(h[n-1]!=z[k]){
        k++;
    }
    BiNode<DataType> *t=new BiNode<DataType>(h[n-1]);
    t->lchild=Creat(h,z,k);
    t->rchild=Creat(h+k,z+k+1,n-1-k);
    return t;

}
int c=0;
template <class DataType>
void BiTree<DataType> :: LeverOrder( )
{
  	BiNode<DataType> *Q[100], *q = nullptr;      //顺序队列最多100个结点
  	int front = -1, rear = -1;                      //队列初始化
  	if (root == nullptr) return;                    //二叉树为空,算法结束
  	Q[++rear] = root;                           //根指针入队
  	while (front != rear)          //当队列非空时
  	{
		q = Q[++front];
		if(c==0){
            cout << q->data;
            c=1;
		}else{
		    cout <<" "<< q->data;
		}
        if (q->lchild != nullptr)  Q[++rear] = q->lchild;
	  	if (q->rchild != nullptr)  Q[++rear] = q->rchild;


  	}
}
int main( )
{
	BiTree<int> asd;
    asd.LeverOrder();
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值