J - 迷宫问题 poj 3984 (bfs+输出路径)

Description

定义一个二维数组:

int maze[5][5] = {

0, 1, 0, 0, 0,

0, 1, 0, 1, 0,

0, 0, 0, 0, 0,

0, 1, 1, 1, 0,

0, 0, 0, 1, 0,
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 7
  • 8
  • 9

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output

左上角到右下角的最短路径,格式如样例所示。
Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

首先在结构体中添加一个父节点索引的变量,用来保存每一步的上一步,所以我只需要访问右下角的父节点,然后一层一层往上寻找,直到左上角为止,当然这里时要求顺序输出,所以可以用一个数组或者栈来保存路径

我也思考过在结构体中添加一个子节点的变量,但仔细思考后甚觉不妥,一个节点有几个子节点,你并不清楚该走哪一条,而父节点则时唯一(应该没人认为你有几个爸爸吧)

 

#include<iostream>
#include<cstdio>
using namespace std;
short int next[4][2]={{0,1},{1,0},{-1,0},{0,-1}};
struct Que{
	short int x,y;
	short int f;
}; 

int book[6][6]={0};
int a[6][6];
int pos[6][6]={0};//保存路径
int main()
{
	struct Que que[100];
	short int head=0,tail=0;
	for(int i = 0;i < 5;++i)
	   for(int j = 0;j < 5;++j)
	      cin >> a[i][j];
	que[tail].x = 0;
	que[tail++].y = 0;
	//que[tail++].f = 0;
	while(head < tail)
	{
		struct Que temp = que[head];
		temp.f = head;
		head++;
		int flag = 0;
		for(int k = 0;k < 4;++k)
		{
			short int tx = temp.x+next[0][k];
			short int ty = temp.y+next[1][k];
			if(tx < 0 || tx >= 5 || ty < 0 || ty >= 5)  continue;
			if(!book[tx][ty] && a[tx][ty] == 0)
			{
				que[tail].x = tx;
				que[tail].y = ty;
				que[tail++].f = temp.f;
				book[tx][ty] = 1;
			}
			
			if(tx == 4 && ty == 4)
			  {
			  	  flag = 1;
			  	  break;
			  }
		}
		if(flag)
		   break;
	}
	int t = tail-1;//获取最后节点
	pos[0][0] = 1;
	while(t)   //将路径保存到数组中
	{
		pos[que[t].x][que[t].y] = 1;
		t = que[t].f;
	}
    for(int i = 0;i < 5;++i)
	   for(int j = 0;j < 5;++j) 
	   {
	   	  if(pos[i][j])
	   	     printf("(%d, %d)\n",i,j);
	   }
	return 0;
}

 

根据提供的引用内容,可以得知这是一道关于迷宫问题题目,需要使用Java语言进行编写。具体来说,这道题目需要实现一个迷宫的搜索算法,找到从起点到终点的最短路径。可以使用广度优先搜索或者深度优先搜索算法来解决这个问题。 下面是一个使用广度优先搜索算法的Java代码示例: ```java import java.util.*; public class Main { static int[][] maze = new int[5][5]; // 迷宫地图 static int[][] dir = {{0, 1}, {0, -1}, {1, 0}, {-1, 0}}; // 方向数组 static boolean[][] vis = new boolean[5][5]; // 标记数组 static int[][] pre = new int[5][5]; // 记录路径 public static void main(String[] args) { Scanner sc = new Scanner(System.in); for (int i = 0; i < 5; i++) { for (int j = 0; j < 5; j++) { maze[i][j] = sc.nextInt(); } } bfs(0, 0); Stack<Integer> stack = new Stack<>(); int x = 4, y = 4; while (x != 0 || y != 0) { stack.push(x * 5 + y); int t = pre[x][y]; x = t / 5; y = t % 5; } stack.push(0); while (!stack.empty()) { System.out.print(stack.pop() + " "); } } static void bfs(int x, int y) { Queue<Integer> qx = new LinkedList<>(); Queue<Integer> qy = new LinkedList<>(); qx.offer(x); qy.offer(y); vis[x][y] = true; while (!qx.isEmpty()) { int tx = qx.poll(); int ty = qy.poll(); if (tx == 4 && ty == 4) { return; } for (int i = 0; i < 4; i++) { int nx = tx + dir[i][0]; int ny = ty + dir[i][1]; if (nx >= 0 && nx < 5 && ny >= 0 && ny < 5 && maze[nx][ny] == 0 && !vis[nx][ny]) { vis[nx][ny] = true; pre[nx][ny] = tx * 5 + ty; qx.offer(nx); qy.offer(ny); } } } } } ``` 该代码使用了广度优先搜索算法,首先读入迷宫地图,然后从起点开始进行搜索,直到找到终点为止。在搜索的过程中,使用标记数组记录已经访问过的位置,使用路径数组记录路径。最后,使用栈来输出路径
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值