欧拉函数,欧拉筛

The Euler function phi is an important kind of function in number theory, (n) represents the amount of the numbers which are smaller than n and coprime to n, and this function has a lot of beautiful characteristics. Here comes a very easy question: suppose you are given a, b, try to calculate (a)+ (a+1)+....+ (b)

 

Input

There are several test cases. Each line has two integers a, b (2<a<b<3000000).

 

Output

Output the result of (a)+ (a+1)+....+ (b)

 

Sample Input

 

3 100

 

Sample Output

 

3042

欧拉函数的板子题。

有个公式 当 p为素数时φ(p) = p - 1

若p是a的因子  φ(p * a) = φ(a) * p 否则  φ(p * a) = φ(a) * (p - 1) 这里的a为任意数因此p为素数 p  - 1 = φ(p)

 

#include <queue>
#include <cstdio>
#include <set>
#include <string>
#include <stack>
#include <cmath>
#include <climits>
#include <map>
#include <cstdlib>
#include <iostream>
#include <vector>
#include <algorithm>
#include <cstring>
#include <stdio.h>
#include <ctype.h>
#include <bitset>
#define  LL long long
#define  ULL unsigned long long
#define mod 10007
#define INF 0x7ffffff
#define mem(a,b) memset(a,b,sizeof(a))
#define MODD(a,b) (((a%b)+b)%b)
//#define maxn 50
using namespace std;
const int maxn = 3000010;
int n,m;
int prime[maxn];
int phi[maxn];
int vis[maxn];
void orla(int x)
{
    int index = 0;
    for(int i = 2; i < x; i++){
       if(!vis[i]) {prime[index++] = i;phi[i] = i - 1;}
       for(int j = 0; j < x && i * prime[j] < x; j++){
         vis[i * prime[j]] = 1;
         if(i % prime[j] == 0){
            phi[i * prime[j]] = (phi[i] * prime[j]);
            break;
         }
         else phi[i * prime[j]] = (phi[i] * phi[prime[j]]);
       }
    }
}
void init(int n)
{
   for(int i = 1; i < n; i++){
     phi[i] += phi[i - 1];
   }
}
int main()
{
    int a,b;
    orla(maxn);
    //init(maxn);

    while(~scanf("%d%d",&a,&b)){
           LL sum = 0;
      for(int i = a; i <= b; i++){
        sum+=phi[i];
      }
    printf("%lld\n",sum);
    }



    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值