「POJ2195」Going Home【最小费用最大流】

Going Home

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 26947 Accepted: 13442

Description

On a grid map there are n little men and n houses. In each unit time, every little man can move one unit step, either horizontally, or vertically, to an adjacent point. For each little man, you need to pay a $1 travel fee for every step he moves, until he enters a house. The task is complicated with the restriction that each house can accommodate only one little man.

Your task is to compute the minimum amount of money you need to pay in order to send these n little men into those n different houses. The input is a map of the scenario, a ‘.’ means an empty space, an ‘H’ represents a house on that point, and am ‘m’ indicates there is a little man on that point.

You can think of each point on the grid map as a quite large square, so it can hold n little men at the same time; also, it is okay if a little man steps on a grid with a house without entering that house.

Input

There are one or more test cases in the input. Each case starts with a line giving two integers N and M, where N is the number of rows of the map, and M is the number of columns. The rest of the input will be N lines describing the map. You may assume both N and M are between 2 and 100, inclusive. There will be the same number of 'H’s and 'm’s on the map; and there will be at most 100 houses. Input will terminate with 0 0 for N and M.

Output

For each test case, output one line with the single integer, which is the minimum amount, in dollars, you need to pay.

Sample Input

2 2
.m
H.
5 5
HH..m
.....
.....
.....
mm..H
7 8
...H....
...H....
...H....
mmmHmmmm
...H....
...H....
...H....
0 0

Sample Output

2
10
28

题意

  • k k k个人, k k k个目的地,一个人去一个目的地,求最小总路程

题解

  • 建立超级源点 s s s,超级汇点 t t t,s和每个人连边,容量为设1,单位花费0,每个人和每个房子连边,容量设为1,单位花费设为人与房子距离,每个房子和t连边,容量设为1,花费为0,跑最小费用最大流

代码

#include<iostream>
#include<cstdio>
#include<queue>

using namespace std;
const int maxn=1e4+10;
const int maxm=3e6+10;
#define inf 0x3f3f3f3f

int n,m,head[maxn],tot,max_flow,pre[maxn],inq[maxn],dis[maxn];
struct node{
	int to,w,c,next;
	node(int a=0,int b=0,int d=0,int e=0){
		to=a;w=b;c=d;next=e;
	}
}edge[maxm];

void add_edge(int u,int v,int w,int c)
{
	edge[++tot]=node(v,w,c,head[u]);
	head[u]=tot;
}

bool spfa(int s,int t)
{
	memset(dis,0x3f,sizeof(dis));
	memset(inq,0,sizeof(inq));
	memset(pre,-1,sizeof(pre));
	//for(int i=0;i<=n;i++) dis[i]=inf,inq[i]=0,pre[i]=-1;
	queue<int> que;que.push(s);inq[s]=1;dis[s]=0;
	while(!que.empty()){
		int cur=que.front();que.pop();inq[cur]=0;
		for(int i=head[cur];i!=-1;i=edge[i].next){
			if(edge[i].w&&dis[cur]+edge[i].c<dis[edge[i].to]){
				dis[edge[i].to]=dis[cur]+edge[i].c;
				pre[edge[i].to]=i;
				if(!inq[edge[i].to]){
					que.push(edge[i].to);
					inq[edge[i].to]=1;
				}
			}
		}
	}
	return pre[t]!=-1;
}

int min_cost(int s,int t)
{
	int cost=0;
	while(spfa(s,t)){
		int minn=inf;
		for(int i=t;i!=s;i=edge[pre[i]^1].to) {
			minn=min(minn,edge[pre[i]].w);
		}
		for(int i=t;i!=s;i=edge[pre[i]^1].to) {
			edge[pre[i]].w-=minn;
			edge[pre[i]^1].w+=minn;
			cost+=minn*edge[pre[i]].c;
		}
		max_flow+=minn;
	}
	return cost;
}

int house[maxn][2],tot2=0,man[maxn][2],tot1=0;
char mp[105][105];

int dist(int i,int j)
{
	return abs(man[i][0]-house[j][0])+abs(man[i][1]-house[j][1]);
}

int main()
{
	while(scanf("%d %d",&n,&m)&&n){
		memset(head,-1,sizeof(head));tot=-1;tot1=tot2=0;
		for(int i=1;i<=n;i++){
			scanf("%s",mp[i]+1);
			for(int j=1;j<=m;j++){
				if(mp[i][j]=='m') man[++tot1][0]=i,man[tot1][1]=j;
				else if(mp[i][j]=='H') house[++tot2][0]=i,house[tot2][1]=j;
			}
		}
		int s=tot1+tot2+1,t=tot1+tot2+2;
		for(int i=1;i<=tot1;i++) add_edge(s,i,1,0),add_edge(i,s,0,0);
		for(int i=1;i<=tot1;i++) for(int j=1;j<=tot2;j++) add_edge(i,j+tot1,1,dist(i,j)),add_edge(j+tot1,i,0,-dist(i,j));
		for(int i=1;i<=tot2;i++) add_edge(i+tot1,t,1,0),add_edge(t,i+tot1,0,0);
		
		int ans=min_cost(s,t);
		printf("%d\n",ans);
	}

}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值