求树中两点距离的最大值(树的直径)

Given a tree (a connected graph with no cycles), you have to find the farthest nodes in the tree. The edges of the tree are weighted and undirected. That means you have to find two nodes in the tree whose distance is maximum amongst all nodes.

Input

Input starts with an integer T (≤ 10), denoting the number of test cases.

Each case starts with an integer n (2 ≤ n ≤ 30000) denoting the total number of nodes in the tree. The nodes are numbered from 0 to n-1. Each of the next n-1 lines will contain three integers u v w (0 ≤ u, v < n, u ≠ v, 1 ≤ w ≤ 10000) denoting that node u and v are connected by an edge whose weight is w. You can assume that the input will form a valid tree.

Output

For each case, print the case number and the maximum distance.

Sample Input

2

4

0 1 20

1 2 30

2 3 50

5

0 2 20

2 1 10

0 3 29

0 4 50

Sample Output

Case 1: 100

Case 2: 80

代码:
https://www.cnblogs.com/a-clown/p/6131346.html

#include<cstdio>
#include<queue>
#include<algorithm>
#include<iostream>
#include<cmath>
#include<cstring>
using namespace std;
#define N 32200
#define INF 0xfffffff
int Head[N], cnt, Max, Index, vis[N], d[N];
struct node
{
    int v, L, next;
}e[N*2];

void Add(int u, int v, int L)
{
    e[cnt].L = L;
    e[cnt].v = v;
    e[cnt].next = Head[u];
    Head[u] = cnt++;
}
void bfs(int u)
{
    memset(vis, 0, sizeof(vis));
    queue<int>Q;
    int p, q;
    d[u]=0;
    vis[u]=1;
    Q.push(u);
    while(Q.size())
    {
        p=Q.front();
        Q.pop();
        for(int i=Head[p]; i!=-1; i=e[i].next)
        {
            q=e[i].v;
            if(!vis[q])
            {
                vis[q]=1;
                d[q] = d[p] + e[i].L;
                Q.push(q);
                if(Max<d[q])
                {
                    Max = d[q];
                    Index = q;
                }
            }
        }
    }
}
int main()
{
    int T, n, t=1, a, b, c;
    cin>>T;
    while(T--)
    {
        memset(Head, -1, sizeof(Head));
        memset(d, 0, sizeof(d));
        cnt = 0;
       cin>>n;
        for(int i=1; i<n; i++)
        {
            cin>>a>>b>>c;
            Add(a+1, b+1, c);
            Add(b+1, a+1, c);
        }
        Max = 0; Index = -1;
        bfs(1);
        bfs(Index);
        printf("Case %d: %d\n", t++, Max);
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值