1045 Favorite Color Stripe (30分)

帮助Eva从给定的色带中找到最长的,由她最喜欢的颜色组成的不递减子序列。使用动态规划解决这个问题,输出子序列的最大长度。
摘要由CSDN通过智能技术生成

题目

Eva is trying to make her own color stripe out of a given one. She would like to keep only her favorite colors in her favorite order by cutting off those unwanted pieces and sewing the remaining parts together to form her favorite color stripe.

It is said that a normal human eye can distinguish about less than 200 different colors, so Eva’s favorite colors are limited. However the original stripe could be very long, and Eva would like to have the remaining favorite stripe with the maximum length. So she needs your help to find her the best result.

Note that the solution might not be unique, but you only have to tell her the maximum length. For example, given a stripe of colors {2 2 4 1 5 5 6 3 1 1 5 6}. If Eva’s favorite colors are given in her favorite order as {2 3 1 5 6}, then she has 4 possible best solutions {2 2 1 1 1 5 6}, {2 2 1 5 5 5 6}, {2 2 1 5 5 6 6}, and {2 2 3 1 1 5 6}.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N ( ≤ 200 ) N(\le200) N(200) which is the total number of colors involved (and hence the colors are numbered from 1 1 1 to N N N). Then the next line starts with a positive integer M ( ≤ 200 ) M(\le200) M(200) followed by M M M Eva’s favorite color numbers given in her favorite order. Finally the third line starts with a positive integer L ( ≤ 1 0 4 ) L(\le10^4) L(104) which is the length of the given stripe, followed by L L L colors on the stripe. All the numbers in a line a separated by a space.

Output Specification:

For each test case, simply print in a line the maximum length of Eva’s favorite stripe.

Sample Input:

6
5 2 3 1 5 6
12 2 2 4 1 5 5 6 3 1 1 5 6

Sample Output:

7

题目大意

给出M中颜色作为喜欢的颜色(同时也给出顺序),然后给出一串长度为L的颜色序列,现在要去掉这个序列中的不喜欢的颜色,然后求剩下序列的一个子序列,使得这个子序列表示的颜色顺序符合自己喜欢的颜色的顺序,不一定要所有喜欢的颜色都出现。

思路

题目只要求输出最长的子序列长度,因此我们可以把输入序列做如下处理:

  1. 当前颜色不是喜欢的颜色,直接去掉;
  2. 当前颜色是喜欢的序列,按已给出的喜欢的颜色顺序编号,把编号存入(把颜色序列转换位编号序列);
    那么这样想的话,这个题就转换为求最长子序列问题,这个最长子序列的要求就是不递减序列,这里我们采用动态规划方法求解;

代码

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

int fav[201];
int ls[10000], dp[10000];

int main(){
    int n, m, l;
    fill(fav, fav+201, 0);
    scanf("%d %d", &n, &m);    // 个人觉得n是个多余的数据,没用上哈哈
    int cnt = 1;
    for(int i=0; i<m; i++){
        int t;
        scanf("%d", &t);
        fav[t] = cnt++;
    }
    cnt = 0;
    scanf("%d", &l);
    for(int i=0; i<l; i++){
        int t;
        scanf("%d", &t);
        if(fav[t] > 0)
            ls[cnt++] = fav[t];    // 存储喜欢颜色的顺序
    }
    // 动规求解
    // 记录动规得出的最大值
    int ans = 0;
    for(int i=0; i<cnt; i++){
        dp[i] = 1;
        for(int j=0; j<i; j++){
            if(ls[i] >= ls[j])
                dp[i] = max(dp[i], dp[j]+1);
        }
        ans = max(ans, dp[i]);
    }
    printf("%d\n", ans);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值