1093 Count PAT's (25分)

题目

The string APPAPT contains two PAT's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT's contained in the string.

Input Specification:

Each input file contains one test case. For each case, there is only one line giving a string of no more than 1 0 5 10^5 105 characters containing only P, A, or T.

Output Specification:

For each test case, print in one line the number of PAT's contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

Sample Input:

APPAPT

Sample Output:

2

题目大意

在一个由P,A,T组成的字符串中,找出能组成PAT的子串的数量,只要满足PAT在原串中的相对顺序不变,就视为满足条件的子串。

思路

我觉得这算是一道技巧题吧,显然应该从PAT中的某一个字符入手,经过一番思考,选择从A入手可以很轻松解决问题,我们这样来看:

  1. 从前向后遍历,定义计数器记录P出现的次数,当遍历到A时,记录这个A之前P出现的次数;
  2. 从后向前遍历,定义计数器记录T出现的次数,当遍历到A时,记录这个A之后T出现的次数;
  3. 经过1,2两个步骤,每个A前后PT的数量都已记录下进来;
  4. 再遍历一边数组,当遇到A时,我们将这个A前后的PT数量相乘,就得到包含这个A的PAT子串的数量,左右累加起来就是最终答案,注意每次MOD一下就行;

代码

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

int main(){
    string text;
    int sum = 0;
    int len, p[100000], t[100000];
    cin>>text;
    len = text.length();
    fill(p, p+len, 0);
    fill(t, t+len, 0);
    int t1 = 0, t2 = 0;
    for(int i=0; i<len; i++){
        if(text[i] == 'P')
            t1++;
        if(text[len-i-1] == 'T')
            t2++;
        if(text[i] == 'A')
            p[i] = t1;
        if(text[len-i-1] == 'A')
            t[len-i-1] = t2;
    }
    for(int i=0; i<len; i++){
        if(text[i] == 'A'){
            sum = (sum + p[i]*t[i]) % 1000000007;
        }
    }
    printf("%d\n", sum);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值