低位选择问题

Problem Description
LL is very lazy. Recently, he is assigned to a dormitory in the 5th floor and sometimes it's hard for him to decide whether to step out for some snack at night. So he choose two positive integers x, y and decide to go or not to go by the low bit of x (l is the length of x in binary representation). If it is "1", he choose to go and if it is "0", he stay in the dormitory.

Input
Each line contain two positive integers a and b (both not larger than 10^7 and a<=b). x is randomly chosen from [a,b]. No limit on y.

Output
For each case, output the probability (accurate to 6 fractional digits) of getting "1".

Sample Input
1 1
3 5

Sample Output
1.000000
0.666667

#include<stdio.h>
int main() {
    int a, b, count;
    while (1) {
        count = 0;
        scanf("%d%d", &a, &b);
        count = (b - a) >> 1;
        if (a & 1 || b & 1)
            ++count;
        printf("%0.6lf\n", count / double(b - a + 1));
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值