A - Where is the Marble?

Raju and Meena love to play with Marbles. They have got a lot of marbles with numbers written on them. At the beginning, Raju would place the marbles one after another in ascending order of the numbers written on them. Then Meena would ask Raju to find the first marble with a certain number. She would count 1...2...3. Raju gets one point for correct answer, and Meena gets the point if Raju fails. After some fixed number of trials the game ends and the player with maximum points wins. Today it’s your chance to play as Raju. Being the smartkid, you’d be taking the favor of a computer. But don’t underestimate Meena, she had written a program to keep track how much time you’re taking to give all the answers. So now you have to write a program, which will help you in your role as Raju.

Input

There can be multiple test cases. Total no of test cases is less than 65. Each test case consists begins with 2 integers: N the number of marbles and Q the number of queries Mina would make. The next N lines would contain the numbers written on the N marbles. These marble numbers will not come in any particular order. Following Q lines will have Q queries. Be assured, none of the input numbers are greater than 10000 and none of them are negative.

  Input is terminated by a test case where N = 0 and Q = 0.

Output

For each test case output the serial number of the case.

  For each of the queries, print one line of output. The format of this line will depend upon whether or not the query number is written upon any of the marbles. The two different formats are described below:

  • ‘x found at y’, if the first marble with number x was found at position y. Positions are numbered 1, 2, . . . , N.

  • ‘x not found’, if the marble with number x is not present.

  Look at the output for sample input for details.

Sample Input

4 1

2

3

5

1

5

5 2

1

3

3

3

1

2

3

0 0

Sample Output

CASE# 1:

5 found at 4

CASE# 2:

2 not found

3 found at 3

题意简述: 输入n个整数,代表大理石编号;再输入q个数(编号),问是否有这个编号的大理石,位置在哪里?

思路: 水题,对输入的数字排序,循环就行,注意输出格式

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<vector>
using namespace std;

vector <int> v;
vector <int> a;
int main() {
	int n,m,q;
	int k=0;
	while(~scanf("%d %d",&n,&q)&&(n+q)) {
		printf("CASE# %d:\n",++k);
		while(!v.empty()) v.pop_back();
		while(!a.empty()) a.pop_back();
		for(int i=0; i<n; i++) {
			scanf("%d",&m);
			v.push_back(m);
		}
		sort(v.begin(),v.end());
		for(int i=0; i<q; i++) {
			scanf("%d",&m);
			a.push_back(m);
		}

		for(int i=0; i<a.size(); i++) {
			int f=1;
			for(int j=0; j<v.size(); j++) {
				if(v[j]==a[i]) {
					printf("%d found at %d\n",a[i],j+1);
					f=0;
					break;
				}
			}
			if(f) printf("%d not found\n",a[i]);
		}
	}
return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Gong JX

多谢鼓励

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值