1144 The Missing Number (20 分)

Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.

Output Specification:

Print in a line the smallest positive integer that is missing from the input list.

Sample Input:

10
5 -25 9 6 1 3 4 2 5 17

Sample Output:

7

  

一直百思不得其解,数据明明都在0-100000范围内,为什么数组开到100001后,有个测试点依旧过不去,改用100002后,过去了,难道有输出是100001的数据测试点?奇怪了。 

#include "pch.h"
#include <iostream>
#include<string.h>
#include<stdio.h>
#include<iomanip>
#include<vector>
#include<string>
#include<algorithm>
#include<queue>
#include<map>
#include<math.h>
using namespace std;


int main()
{
	int a[100001];
	int n;
	cin >> n;
	memset(a, 0, sizeof(a));
	for (int i = 0; i < n; i++)
	{
		int b;
		cin >> b;
		if (b > 0 && b < 100001)
			a[b] = 1;
	}
	for(int i=1;i<100001;i++)
		if (a[i] == 0)
		{
			cout << i << endl;
			break;
		}
}

 用map做的过去了。

#include "pch.h"
#include <iostream>
#include<string.h>
#include<stdio.h>
#include<iomanip>
#include<vector>
#include<string>
#include<algorithm>
#include<queue>
#include<map>
#include<math.h>
using namespace std;


int main()
{
	map<int, int>mmp;
	int n;
	cin >> n;
	for (int i = 0; i < n; i++)
	{
		int a;
		cin >> a;
		if (a > 0)
			mmp[a]++;
	}
	for (int i = 1; i < pow(2,32); i++)
		if (mmp[i] == 0)
		{
			cout << i << endl;
			break;
		}
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值