【通过PAT复习C++与数据结构】PAT-A 1153 Decode Registration Card of PAT (25 分)

题目

A registration card number of PAT consists of 4 parts:

the 1st letter represents the test level, namely, T for the top level, A for advance and B for basic;
the 2nd - 4th digits are the test site number, ranged from 101 to 999;
the 5th - 10th digits give the test date, in the form of yymmdd;
finally the 11th - 13th digits are the testee’s number, ranged from 000 to 999.
Now given a set of registration card numbers and the scores of the card owners, you are supposed to output the various statistics according to the given queries.

Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N (≤10
​4
​​ ) and M (≤100), the numbers of cards and the queries, respectively.

Then N lines follow, each gives a card number and the owner’s score (integer in [0,100]), separated by a space.

After the info of testees, there are M lines, each gives a query in the format Type Term, where

Type being 1 means to output all the testees on a given level, in non-increasing order of their scores. The corresponding Term will be the letter which specifies the level;
Type being 2 means to output the total number of testees together with their total scores in a given site. The corresponding Term will then be the site number;
Type being 3 means to output the total number of testees of every site for a given test date. The corresponding Term will then be the date, given in the same format as in the registration card.
Output Specification:
For each query, first print in a line Case #: input, where # is the index of the query case, starting from 1; and input is a copy of the corresponding input query. Then output as requested:

for a type 1 query, the output format is the same as in input, that is, CardNumber Score. If there is a tie of the scores, output in increasing alphabetical order of their card numbers (uniqueness of the card numbers is guaranteed);
for a type 2 query, output in the format Nt Ns where Nt is the total number of testees and Ns is their total score;
for a type 3 query, output in the format Site Nt where Site is the site number and Nt is the total number of testees at Site. The output must be in non-increasing order of Nt’s, or in increasing order of site numbers if there is a tie of Nt.
If the result of a query is empty, simply print NA.

Sample Input:
8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999
Sample Output:
Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA

题目大意

给出一组学生的准考证号和成绩,准考证号包含了等级(乙甲顶),考场号,日期,和个人编号信息,并有三种查询方式
查询一:给出考试等级,找出该等级的考生,按照成绩降序,准考证升序排序
查询二:给出考场号,统计该考场的考生数量和总得分
查询三:给出考试日期,查询改日期下所有考场的考试人数,按照人数降序,考场号升序排序

解题后总结

没有写解题前的思路,因为这道题我没有AC,最后有两个点超时了。(为什么没改正,因为这题做的我心力憔悴……)
这是一道模拟题,考点有:
sort排序;
hash;
字符串处理;
模拟;
思路并不难,也没有什么深奥的算法知识,但是真的好花时间。
因为没有过,我贴一下柳神的代码吧“悄咪咪的觉得,柳神这段代码优化了太多了,不太像是能一次写出来的,我猜是后期优化了(也可能是我太菜了)

柳神的代码

#include <iostream>
#include <vector>
#include <unordered_map>
#include <algorithm>
using namespace std;
struct node {
    string t;
    int value;
};
bool cmp(const node &a, const node &b) {
    return a.value != b.value ? a.value > b.value : a.t < b.t;
}
int main() {
    int n, k, num;
    string s;
    cin >> n >> k;
    vector<node> v(n);
    for (int i = 0; i < n; i++)
        cin >> v[i].t >> v[i].value;
    for (int i = 1; i <= k; i++) {
        cin >> num >> s;
        printf("Case %d: %d %s\n", i, num, s.c_str());
        vector<node> ans;
        int cnt = 0, sum = 0;
        if (num == 1) {
            for (int j = 0; j < n; j++)
                if (v[j].t[0] == s[0]) ans.push_back(v[j]);
        } else if (num == 2) {
            for (int j = 0; j < n; j++) {
                if (v[j].t.substr(1, 3) == s) {
                    cnt++;
                    sum += v[j].value;
                }
            }
            if (cnt != 0) printf("%d %d\n", cnt, sum);
        } else if (num == 3) {
            unordered_map<string, int> m;
            for (int j = 0; j < n; j++)
                if (v[j].t.substr(4, 6) == s) m[v[j].t.substr(1, 3)]++;
            for (auto it : m) ans.push_back({it.first, it.second});
        }
        sort(ans.begin(), ans.end(),cmp);
        for (int j = 0; j < ans.size(); j++)
            printf("%s %d\n", ans[j].t.c_str(), ans[j].value);
        if (((num == 1 || num == 3) && ans.size() == 0) || (num == 2 && cnt == 0)) printf("NA\n");
    }
    return 0;
}

自己的代码

#include<bits/stdc++.h>
using namespace std;
const int maxn=10010;
typedef struct card{
	string ID;
	int score;
}card;
typedef struct newType{
	int num;
	int site;
}newType;
int n,m;//考生总数,查询次数 
card input[maxn];
bool cmp(card a,card b){
	if(a.score!=b.score){
		return a.score>b.score  ;
	}
	else return a.ID <b.ID ;
}
bool cmp2(newType a,newType b){
	if(a.num !=b.num)return a.num>b.num ;
	else return a.site <b.site ;
}
void botton_1(char type){
	int sum=0;
	vector<card> theType;
	for(int i=0;i<n;++i){
		if(input[i].ID[0]==type){
			theType.push_back(input[i]);
		}
	} 
	if(theType.size()==0){
		cout<<"NA";
		return;
	}
	sort(theType.begin() ,theType.end(),cmp);
	for(int i=0;i<theType.size();++i){
		cout<<theType[i].ID<<" "<<theType[i].score;
		if(i<theType.size()-1)cout<<endl;
	}
	
}
void botton_2(string str){
	int sum=0,score=0;
	string temp;
	for(int i=0;i<n;++i){
		temp=input[i].ID.substr(1,3);
		if(temp==str){
			sum++;
			
			score+=input[i].score ;
		}
	}
	if(sum==0){
		cout<<"NA";
		return;
	}
	cout<<sum<<" "<<score;
}

void botton_3(string str){
	string temp;
	int flag=0;
	newType hash[1000];
	for(int i=0;i<1000;++i){
		hash[i].num=0;
		hash[i].site=i;
	}
	for(int i=0;i<n;++i){
		temp=input[i].ID.substr(4,6);
		if(temp==str){
			int site=stoi(input[i].ID.substr(1,3));
			hash[site].num ++;
			flag=1;
		} 
	}
	if(flag==0){
		cout<<"NA";
		return;
	}
	sort(hash,hash+1000,cmp2);
	int sum=0;
	for(int i=0;i<1000;++i){
		if(hash[i].num!=0)++sum;
	}
	for(int i=0;i<sum;++i){
		cout<<hash[i].site<<' '<<hash[i].num;
		if(i<sum-1)cout<<endl;
	}
}

int main(){
	cin>>n>>m;
	for(int i=0;i<n;++i){
		cin>>input[i].ID >>input[i].score ;
	}
	int temp1;
	string temp2;
	char temp3;
	for(int i=1;i<=m;++i){
		cin>>temp1;
		if(temp1==1){
			cin>>temp3;
			cout<<"Case "<<i<<": "<<1<<" "<<temp3<<endl;
			botton_1(temp3);
			if(i<m)cout<<endl;
		}
		else if(temp1==2){
			cin>>temp2;
			cout<<"Case "<<i<<": "<<2<<" "<<temp2<<endl;
			botton_2(temp2);
			if(i<m)cout<<endl;
		}
		else if(temp1==3){
			cin>>temp2;
			cout<<"Case "<<i<<": "<<3<<" "<<temp2<<endl;
			botton_3(temp2);
			if(i<m)cout<<endl;
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值