【通过PAT复习C++与数据结构】PAT-A 1043 Is It a Binary Search Tree (25 分)

题目

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:
For each test case, first print in a line YES if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:
7
8 6 5 7 10 8 11
Sample Output 1:
YES
5 7 6 8 11 10 8
Sample Input 2:
7
8 10 11 8 6 7 5
Sample Output 2:
YES
11 8 10 7 5 6 8
Sample Input 3:
7
8 6 8 5 10 9 11
Sample Output 3:
NO

题目大意

给出一个序列,判断这个序列是不是二叉搜索树的先序遍历序列,或者是二叉搜索树镜像树的先序遍历序列。如果是,输出后序遍历,如果不是,输出NO。

直觉

先根据给定序列还原二叉搜索树,然后再先序遍历判断是否符合条件。
问题是:根据给定序列建立二叉搜索树是否唯一?这里涉及到了数学证明了,我用搜索引擎查到的是

如果是用这个序列去依次构造二叉查找树,则唯一
如果是用这个序列所有的关键字去构造可能的二叉树(排列任意),则一般不唯一

同时还有一个二叉搜索树的镜像树证明处理,其实只要还原后,二叉搜索树的镜像树先序遍历我们只需要交换左右子树遍历顺序即可。

考察知识点

  1. 二叉搜索树建立
  2. 二叉树遍历

复杂度分析

二叉树建立复杂度O(N),二叉树遍历复杂度O(N),N是节点数目

代码

#include<iostream>
#include<vector> 
using namespace std;
typedef struct node{
	int data;
	node* lchild;
	node* rchild;
}node;

void insert(node* &root,int data){
	if(root==NULL){
		root=new node;
		root->data=data;
		root->lchild=root->rchild=NULL;
		return;
	}
	if(data<root->data)insert(root->lchild,data);
	else insert(root->rchild,data);
}
void preorder(node* root,vector<int> &vi){//二叉树先序遍历 
	if(root==NULL)return;
	vi.push_back(root->data);
	preorder(root->lchild,vi);
	preorder(root->rchild,vi);
}

void postorder(node* root,vector<int> &vi){//二叉树后序遍历
	 if(root==NULL)return;
	 postorder(root->lchild,vi);
	 postorder(root->rchild,vi);
	 vi.push_back(root->data);
}

void premorder(node *root,vector<int> &vi){//镜像树的先序遍历 
	if(root==NULL)return;
	vi.push_back(root->data );
	premorder(root->rchild,vi);
	premorder(root->lchild,vi);
}

void postmorder(node* root,vector<int> &vi){//镜像树后续遍历
 	if(root==NULL)return;
	postmorder(root->rchild,vi);
	postmorder(root->lchild,vi);
	vi.push_back(root->data);
} 
vector<int> origin,pre,prem,post,postm; 
int main(){
	int data,n;
	node* root=NULL;
	cin>>n;
	for(int i=0;i<n;++i){
		cin>>data;
		origin.push_back(data);
		insert(root,data);
	}
	preorder(root,pre);
	premorder(root,prem);
	postorder(root,post);
	postmorder(root,postm);
	if(origin==pre){
		cout<<"YES"<<endl;
		for(int i=0;i<post.size();++i){
			cout<<post[i];
			if(i<post.size()-1)cout<<" ";
		}
	}
	else if(origin==prem){
		cout<<"YES"<<endl;
		for(int i=0;i<postm.size();++i){
			cout<<postm[i];
			if(i<postm.size()-1)cout<<" ";
		}
	}
	else cout<<"NO";
	return 0;
}

提交时间 状态 分数 题目 编译器 耗时 用户
2019/8/21 20:00:14
答案正确
25 1043 C++ (g++) 6 ms Chester
测试点 结果 耗时 内存
0 答案正确 3 ms 424 KB
1 答案正确 3 ms 352 KB
2 答案正确 3 ms 384 KB
3 答案正确 3 ms 424 KB
4 答案正确 3 ms 384 KB
5 答案正确 6 ms 356 KB
6 答案正确 5 ms 384 KB
7 答案正确 3 ms 384 KB

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值