1043 Is It a Binary Search Tree (25 分) 根据判断是不是前序还是前序镜像输出后序或者后序镜像

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node's key.
The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
Both the left and right subtrees must also be binary search trees.
If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line YES if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

7
8 6 5 7 10 8 11

Sample Output 1:

YES
5 7 6 8 11 10 8

Sample Input 2:

7
8 10 11 8 6 7 5

Sample Output 2:

YES
11 8 10 7 5 6 8

Sample Input 3:

7
8 6 8 5 10 9 11

Sample Output 3:

NO

题意:输入一个长度为n的序列,判断这个序列是不是前序序列还是前序镜像序列,如果是的话,输出后序或者后序镜像序列。
思路:先写出建树,先序,先序镜像,后序,后序镜像遍历,然后将输入的序列存入到origin中,然后只要比较origin=pre或者origin=prem即可,然后输出后序或者后序镜像遍历。

#include<iostream>
#include<cstdio>
#include<stack> 
#include<queue>
#include<vector>
#include<algorithm>
#include<cstring>
#include<string>
#include<cmath>
#include<set>
#include<map>

using namespace std;

int n;
vector<int> origin,pre,prem,in,post,postm;

struct node {
	int data;
	node *left,*right;
};

void insert(node* &root,int data) {
	if(root == NULL) {
		root = new node;
		root->data = data;
		root->left = root->right = NULL;
		return;
	} else if(data < root->data) {
		insert(root->left,data);
	} else {
		insert(root->right,data);
	}
}

void preorder(node *root,vector<int> &v) {
	if(root == NULL) {
		return;
	}
	v.push_back(root->data);
	preorder(root->left,v);
	preorder(root->right,v);
}

void preorderm(node *root,vector<int> &v) {
	if(root == NULL) {
		return;
	}
	v.push_back(root->data);
	preorderm(root->right,v);
	preorderm(root->left,v);
}

void postorder(node* root,vector<int>& vi) {
	if(root == NULL) {
		return;
	}
	postorder(root->left,vi);
	postorder(root->right,vi);
	vi.push_back(root->data);
}

void postorderm(node* root,vector<int>& vi) {
	if(root == NULL) {
		return;
	}
	postorderm(root->right,vi);
	postorderm(root->left,vi);
	vi.push_back(root->data);
}
 
int main() {
	scanf("%d",&n);
	int data;
	node *root = NULL;	
	for(int i = 0;i < n;i++) {
		scanf("%d",&data);
		origin.push_back(data);
		insert(root,data);
	}
	preorder(root,pre);
	preorderm(root,prem);
	postorder(root,post);
	postorderm(root,postm);
	if(origin == pre) {
		printf("YES\n");
		for(int i = 0;i < n;i++) {
			if(i != 0) {
				cout << " " << post[i]; 
			} else if(i == 0) {
				cout << post[0];
			}
		}
	} else if(origin == prem) {
		printf("YES\n");
		for(int i = 0;i < n;i++) {
			if(i != 0) {
				cout << " " << postm[i];
			} else if(i == 0) {
				cout << postm[0];
			}
		}
	} else {
		printf("NO\n");
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值