Matrix(二维树状数组)

【二维树状数组】

巧妙的运用容斥定理,再结合一维树状数组。

假设我们需要求阴影部分子矩阵的所有元素和,那么我们要如何计算呢?

query(x4,y4)- query(x2,y2)- query(x3,y3)+ query(x1,y1)即可。

夸一下灵魂小画手叭!!

【题目】

Matrix

TimeLimit:3000MS  MemoryLimit:65536K

64-bit integer IO format:%lld

Problem Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).
2. Q x y (1 <= x, y <= n) querys A[x, y].

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above.

Output

For each querying output one line, which has an integer representing A[x, y].

There is a blank line between every two continuous test cases.

SampleInput

1 
2 10 
C 2 1 2 2 
Q 2 2 
C 2 1 2 1 
Q 1 1 
C 1 1 2 1 
C 1 2 1 2 
C 1 1 2 2 
Q 1 1 
C 1 1 2 1 
Q 2 1

SampleOutput

1 
0 
0 
1

【题解】

二维区间修改,二维区间查询。

【代码】

#include<stdio.h>
#include<string.h>
#define lowbit(x) x&(-x)
using namespace std;
int c[1005][1005];
int n;
void update(int x,int t,int v)
{
    while(x<=n)
    {
        int y=t;
        while(y<=n)
        {
            c[x][y]+=v;
            y+=lowbit(y);
        }
        x+=lowbit(x);
    }
}
int query(int x,int t)
{
    int s=0;
    while(x>0)
    {
        int y=t;
        while(y>0)
        {
            s+=c[x][y];
            y-=lowbit(y);
        }
        x-=lowbit(x);
    }
    return s%2;
}
main()
{
    int i,j,t,m,x,y,xx,yy;
    char p;
    scanf("%d",&t);
    while(t--)
    {
        memset(c,0,sizeof(c));
        scanf("%d%d",&n,&m);
        for(i=0;i<m;i++)
        {
            scanf(" %c%d%d",&p,&x,&y);
            if(p=='C')
            {
                scanf("%d%d",&xx,&yy);
                update(x,y,1);
                update(xx+1,y,-1);
                update(x,yy+1,-1);
                update(xx+1,yy+1,1);
            }
            else
                printf("%d\n",query(x,y));
        }
        if(t) printf("\n");
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值