Prime Ring Problem HDU - 1016

22 篇文章 0 订阅

一、内容

 A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

Input

n (0 < n < 20).

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input

6
8

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

二、思路

  • 用线性筛法筛一下质数。
  • dfs枚举环上每一个数的可能,判断与上一个数的和是否是质数,若果是该位置就可以放这个数。
  • 最后特判一下最后一个数与1的和。
  • 注意输出格式,每行后面不要有多余空格,每个case后面多输出一个换行。

三、代码

#include <cstdio>
const int N = 100;
int n, pri[N + 5], cnt, rec[N];//pri保存质数  
bool v[N + 5], vis[N]; //为true代表非质数  vis记录下是否访问过 
//线性筛 筛一下质数
void init() {
	v[1] = true;
	for (int i = 2; i <= N; i++) {
		if (!v[i]) pri[cnt++] = i; //代表是质数
		for (int j = 0; pri[j] <= N / i; j++) {
			v[i * pri[j]] = true;
			if (i % pri[j] == 0) break;
		} 
	} 
} 
void dfs(int step) {
	if (step == n) {
		//代表这找到一种方案 进行输出
		//额外判断一下末尾的与第一个的和
		if (!v[rec[n - 1] + 1])  {
			printf("1");
			for (int i = 1; i < n; i++) printf(" %d", rec[i]);
			printf("\n");
		}
		return;
	}
	//枚举下每个数字
	for (int i = 2; i <= n; i++) {
		if (!vis[i] && !v[i + rec[step - 1]]) {
			vis[i] = true;
			rec[step] = i;
			dfs(step + 1);
			vis[i] = false;
		} 
	} 
} 
int main() {
	init();
	int ci = 1;
	rec[0] = 1;
	while (scanf("%d", &n) != EOF) {
		printf("Case %d:\n", ci++);
		dfs(1);
		printf("\n");//按照格式多打一个换行 
	}
	return 0;
} 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值