【POJ - 2486】Apple Tree (树形背包,dp)

题干:

Wshxzt is a lovely girl. She likes apple very much. One day HX takes her to an apple tree. There are N nodes in the tree. Each node has an amount of apples. Wshxzt starts her happy trip at one node. She can eat up all the apples in the nodes she reaches. HX is a kind guy. He knows that eating too many can make the lovely girl become fat. So he doesn’t allow Wshxzt to go more than K steps in the tree. It costs one step when she goes from one node to another adjacent node. Wshxzt likes apple very much. So she wants to eat as many as she can. Can you tell how many apples she can eat in at most K steps.

Input

There are several test cases in the input 
Each test case contains three parts. 
The first part is two numbers N K, whose meanings we have talked about just now. We denote the nodes by 1 2 ... N. Since it is a tree, each node can reach any other in only one route. (1<=N<=100, 0<=K<=200) 
The second part contains N integers (All integers are nonnegative and not bigger than 1000). The ith number is the amount of apples in Node i. 
The third part contains N-1 line. There are two numbers A,B in each line, meaning that Node A and Node B are adjacent. 
Input will be ended by the end of file. 

Note: Wshxzt starts at Node 1.

Output

For each test case, output the maximal numbers of apples Wshxzt can eat at a line.

Sample Input

2 1 
0 11
1 2
3 2
0 1 2
1 2
1 3

Sample Output

11
2

题目大意:

一颗树,n个点(1-n),n-1条边,每个点上有一个权值,求从1出发,走k步,最多能遍历到的权值。

多组数据 
第一行两个整数N,K 1<=N<=100,0<=k<=200 
第二行N个整数,0<=x<=1000表示每个节点中苹果的数量 
最后N-1行描述两个点相连

解题报告:

每次先对子节点做一遍01背包

dp[i][j]表示在i节点走j步可以得到的最大权值,因为可以发现,答案的数目只跟走的步数有关,而跟这些步数是怎么走的无关,所以设置状态为此。

这里注意的就是有时要走回头路

那么dp[i][j]要加一维,回到根节点或不回到跟节点,加上这个状态是为了方便后去走到其他的儿子节点。

0不回来1回来的话

dp[rt][j][0]=max(dp[rt][j][0],dp[rt][j-k][1]+dp[v][k-1][0]);

不回来的状态 为    其他节点回来并且当前节点不回来

dp[rt][j][0]=max(dp[rt][j][0],dp[rt][j-k][0]+dp[v][k-2][1]);

不回来的状态 为    其他节点不回来 当前节点回来

dp[rt][j][1]=max(dp[rt][j][1],dp[rt][j-k][1]+dp[v][k-2][1]);

回来的状态 为    其他节点都要回来,并且当前儿子也要回来。

AC代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
#include<vector>
#include<set>
#include<string>
#include<cmath>
#include<cstring>
#define ll long long
#define pb push_back
#define pm make_pair
using namespace std;
const int MAX = 205 + 5;
vector<int> vv[MAX];
int n,m;
int dp[MAX][MAX][2],a[MAX]; 
void dfs(int cur,int rt) {
	int up = vv[cur].size();
	for(int i = 0; i<=m; i++) dp[cur][i][0] = dp[cur][i][1] = a[cur];
	for(int i = 0; i<up; i++) {
		int v = vv[cur][i];
		if(v == rt) continue;
		dfs(v,cur);
		for(int j=m; j>=1; j--) {
			for(int k=1; k<=j; k++) {
				dp[cur][j][0]=max(dp[cur][j][0],dp[cur][j-k][1]+dp[v][k-1][0]);
				dp[cur][j][0]=max(dp[cur][j][0],dp[cur][j-k][0]+dp[v][k-2][1]);
				dp[cur][j][1]=max(dp[cur][j][1],dp[cur][j-k][1]+dp[v][k-2][1]);
			}
		}
	}
}
int main()
{
	while(~scanf("%d%d",&n,&m)) {
		for(int i = 1; i<=n; i++) scanf("%d",a+i),vv[i].clear();
		memset(dp,0,sizeof dp);
		for(int a,b,i = 1; i<=n-1; i++) {
			scanf("%d%d",&a,&b);
			vv[a].pb(b);vv[b].pb(a);
		}
		dfs(1,-1);
		printf("%d\n",max(dp[1][m][0],dp[1][m][1]));
	}


	return 0 ;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值