【PAT】A1112 Stucked Keyboard (20)

1112 Stucked Keyboard (20 point(s))

On a broken keyboard, some of the keys are always stucked. So when you type some sentences, the characters corresponding to those keys will appear repeatedly on screen for k times.

Now given a resulting string on screen, you are supposed to list all the possible stucked keys, and the original string.

Notice that there might be some characters that are typed repeatedly. The stucked key will always repeat output for a fixed k times whenever it is pressed. For example, when k=3, from the string thiiis iiisss a teeeeeest we know that the keys i and e might be stucked, but s is not even though it appears repeatedly sometimes. The original string could be this isss a teest.

Input Specification:

Each input file contains one test case. For each case, the 1st line gives a positive integer k (1<k≤100) which is the output repeating times of a stucked key. The 2nd line contains the resulting string on screen, which consists of no more than 1000 characters from {a-z}, {0-9} and _. It is guaranteed that the string is non-empty.

Output Specification:

For each test case, print in one line the possible stucked keys, in the order of being detected. Make sure that each key is printed once only. Then in the next line print the original string. It is guaranteed that there is at least one stucked key.

Sample Input:

3
caseee1__thiiis_iiisss_a_teeeeeest

Sample Output:

ei
case1__this_isss_a_teest

#include <iostream>
#include <map>
#include <unordered_set>
//#include <fstream>
using namespace std;
map<char, int> mci;
unordered_set<char> si;
int main() {
    //ifstream cin("/home/my/Desktop/in.txt");
    int k, cnt = 1;
    string s, res;
    cin >> k >> s;
    s += "#";                                           // 末尾加一个不会出现的字符
    for(int i = 0; i < s.size() - 1; i++){              // 找到不可能是坏键的键(其余都是坏键)
        if(s[i] == s[i + 1]){                           // 如果这个字符和下个字符相同,计数++
            cnt++;
        } else if(s[i] != s[i + 1] && cnt % k != 0){    // 如果不同,且计数不是k的倍数,则不可能是坏键
            mci[s[i]] = -1;     // 设为非坏键
            cnt = 1;            // 计数从1开始(下一个字符就是第一个重复的字符)
        } else {
            cnt = 1;            //字符不同,计数是k的倍数,则可能是坏键,先不做处理
        }
    }
    for(int i = 0; i < s.size() - 1; i++){              // 输出坏键
        if(mci[s[i]] != -1 && si.find(s[i]) == si.end()) {  // 找到坏键,并且之前未出现过
            printf("%c", s[i]);
            si.insert(s[i]);
        }
        if(mci[s[i]] != -1) {   // 删除后两个相同字符
            s.erase(i, k - 1);
        }
    }
    s = s.substr(0, s.length() - 1);                    // 把最后的一个字符“#”去掉
    printf("\n%s", s.c_str());
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值