1112 Stucked Keyboard (20 point(s)) PAT甲级

1112 Stucked Keyboard (20 point(s))

字符串

题目

On a broken keyboard, some of the keys are always stucked. So when you type some sentences, the characters corresponding to those keys will appear repeatedly on screen for k times.

Now given a resulting string on screen, you are supposed to list all the possible stucked keys, and the original string.

Notice that there might be some characters that are typed repeatedly. The stucked key will always repeat output for a fixed k times whenever it is pressed. For example, when k=3, from the string thiiis iiisss a teeeeeest we know that the keys i and e might be stucked, but s is not even though it appears repeatedly sometimes. The original string could be this isss a teest.

Input Specification:

Each input file contains one test case. For each case, the 1st line gives a positive integer k (1<k≤100) which is the output repeating times of a stucked key. The 2nd line contains the resulting string on screen, which consists of no more than 1000 characters from {a-z}, {0-9} and _. It is guaranteed that the string is non-empty.

Output Specification:

For each test case, print in one line the possible stucked keys, in the order of being detected. Make sure that each key is printed once only. Then in the next line print the original string. It is guaranteed that there is at least one stucked key.

Sample Input:

3
caseee1__thiiis_iiisss_a_teeeeeest

Sample Output:

ei
case1__this_isss_a_teest

思路

unordered_map<char, bool>存储stucked key。用全局变量cnt存储每个重复字符的变化即可。如果flag值需要随时更新,需要用两个bool数组存储。

注意

**pat的编译器和vs不一样!!!**bool数组最好要初始化={false}if(xxx==true)写成if(xxx)unordered_map的存储顺序也很迷惑?

代码

#include<iostream>
#include<unordered_map>
#include<string>
using namespace std;

int main() {
    unordered_map<char, bool> m;
    bool mark[256] = {false};
    int k, cnt = 1;
    string str;
    char pre;
    scanf("%d", &k);
    cin >> str;
    pre = str[0];
    for (int i = 1; i < str.length(); i++) {
        if (str[i] == pre)
            cnt++;
        else {
            if (cnt % k != 0) {
                mark[pre] = true;
            }
            cnt = 1;
        }
        pre = str[i];
    }
    if (cnt % k != 0) {
        mark[str[str.length() - 1]] = true;
    }

    for (int i = 0; i < str.length(); i++) {
        if (!mark[str[i]] && m.find(str[i]) == m.end()){
            m[str[i]] = true;
            printf("%c", str[i]);
        }
    }
    printf("\n");
    for (int i = 0; i < str.length(); i++) {
        printf("%c", str[i]);
        if (m[str[i]])
            i = i + k - 1;
    }
    printf("\n");
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值