[C++] PAT#A#1007 Maximum Subsequence Sum (25分)

Given a sequence of K integers { N1, N2, …, NK }. A continuous subsequence is defined to be { Ni, Ni+1, …, Nj } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21 

Sample Output:

10 1 4

题意给出一个序列,让你从中找出最大连续子序列,输出子序列和,序列的第一个和最后一个元素。当给出的序列全为负数时,输出0,第一个数和最后一个数。当多个子序列和相等时,输出坐标最小的那个子序列。

思路:我是直接照搬柳神的了,因为我自己写的那个憨憨代码,太长而且很多个测试点都过不了。这道题算是第一次正式做的dp类的题,(之前看的01背包只停留在纸面上),柳神的思路就是用tempindex和temp存储临时序列,temp为负就更新tempindex为i+1,temp>sum,就更新left和right,当然最妙的是将right初始化为n-1,避免了在输入时挨个检查是否为负。

上大佬的代码:

#include <iostream>
#include <vector>
#include <cmath>
using namespace std;

int main() {
	int n;
	scanf("%d", &n);
	vector<int> v(n);
	int left = 0, right = n - 1, temp = 0, sum = -1, tempindex = 0;
	for (int i = 0; i < n; i++) {
		scanf("%d", &v[i]);
		temp += v[i];
		if (temp < 0) {
			temp = 0;
			tempindex = i + 1;
		} else if (temp > sum) {
			sum = temp;
			left = tempindex;
			right = i;
		}
	} 
	if (sum < 0) sum = 0;
	printf("%d %d %d", sum, v[left], v[right]);
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值