A1007 Maximum Subsequence Sum (25 分)PAT甲级真题(C++)【最大子序列和+动态规划】

Given a sequence of K integers { N1​, N2​, ..., NK​ }. A continuous subsequence is defined to be { Ni​, Ni+1​, ..., Nj​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

经典的一道动态规划题

要求最大子序列和,可以考虑舍去负值,因为加上一个负值反而会让值变小,所以在遇到负值时,就断开原先计算的那个子序列,重新开始

代码如下:

其中,max是最后要求的最大值,tempSum是当前计算的子序列的和,left是最后的最大子序列的起始索引,right是最后最大子序列的终止索引,tempLeft是计算途中临时的子序列起始索引

#include<iostream>
#include<vector>
using namespace std;
int main()
{
    int k;
    scanf("%d",&k);//数的个数
    vector<int> num(k);
    int max=-1,tempSum=0,left=0,right=k-1,tempLeft=0;//tempLeft存放临时的left值
    for(int i=0;i<k;i++)
    {
        scanf("%d",&num[i]);
        tempSum+=num[i];
        if(tempSum<0)//负数则直接舍去
        {
            tempSum=0;//重新从0开始
            tempLeft=i+1;
        }else if(tempSum>max){
            max=tempSum;
            left=tempLeft;
            right=i;
        }
    }
    if(max<0)max=0;
    //max的初值设为了-1,而计算方法是直接舍去负值,只计算正值,所以最后结果<0的情况只有max=-1,即所有数都为负数,此时的left和right也刚好没有被更新过,仍然是0和k-1
    printf("%d %d %d",max,num[left],num[right]);
    return 0;
}

运行结果如下:

注意,在代码中,tempLeft一定要赋初值为0,不然第4个测试点会有段错误,这是因为如果一开始的数都是正数,则不会进入第一个if语句判断而直接进入第二个else if,此时的tempLeft是没有值的,再进行left=tempLeft的赋值自然会出错(这是我做的时候一时大意踩的一个小坑...)

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值