hdu 2859 Phalanx

Today is army day, but the servicemen are busy with the phalanx for the celebration of the 60th anniversary of the PRC. 
A phalanx is a matrix of size n*n, each element is a character (a~z or A~Z), standing for the military branch of the servicemen on that position. 
For some special requirement it has to find out the size of the max symmetrical sub-array. And with no doubt, the Central Military Committee gave this task to ALPCs. 
A symmetrical matrix is such a matrix that it is symmetrical by the “left-down to right-up” line. The element on the corresponding place should be the same. For example, here is a 3*3 symmetrical matrix: 
cbx 
cpb 
zcc

Input


There are several test cases in the input file. Each case starts with an integer n (0<n<=1000), followed by n lines which has n character. There won’t be any blank spaces between characters or the end of line. The input file is ended with a 0.

Output


Each test case output one line, the size of the maximum symmetrical sub- matrix. 

Sample Input


3
abx
cyb
zca
4
zaba
cbab
abbc
cacq
0

Sample Output


3
3

题目意思比较好理解,找一个矩阵中的最大对称矩阵大小,对称矩阵的对称轴为左下到右上。因为对称肯定是正方形,所以只要输出一个数就行了。

用一个dp[i][j]储存点a[i][j]作为对称轴起点(即对称轴左下角的点)的时候能求得的最大对称矩阵的大小。这样的话我们可以很容易得到两个结论:1、dp[i][j]的最小值/初始值为1.因为长度为1时就一个数。2、dp[i][j]的大小取决于dp[i-1][j+1],即该点作为对称轴的上一点。若上一点的值为x,且拓展出的矩阵也对称,则dp[i][j]就等于dp[i-1][j+1]+1(在原来矩阵大小上多拓展一个)。

然后要注意因为对称轴的上边界是右上 所以要从行末开始遍历。

AC代码:

/*#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
char a[1010][1010];
int dp[1010][1010];
int maxx;
void solve(int x,int y)
{
    int t=dp[x-1][y-1];
    for(int i=1;i<=t;i++)
    {
        if(a[x-i][y]!=a[x][y-i])
            break;
        if(i==t) dp[x][y]=t+1;
        else dp[x][y]=i;
        maxx=max(maxx,dp[x][y]);
    }
}
int main()
{
    int n;
    while(cin>>n&&n)
    {
        memset(dp,0,sizeof(dp));
        maxx=0;
        for(int i=n;i>=1;i--)
            scanf("%s",&a[i][1]);
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
                solve(i,j);
        cout<<maxx<<endl;
    }
    return 0;
}

*/
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
char a[1010][1010];
int dp[1010][1010];
int main()
{
    int n;
    while(cin>>n&&n)
    {
        for(int i=0;i<n;i++)
            scanf("%s",a[i]);
        int maxx=1;
        for(int i=0;i<n;i++)
            for(int j=n-1;j>=0;j--)
        {
            dp[i][j]=1;
            if(i==0||j==n-1) continue;
            int t=dp[i-1][j+1];
            for(int k=1;k<=t;k++)
            {
                if(a[i-k][j]!=a[i][j+k]) break;
                dp[i][j]++;
            }
            maxx=max(maxx,dp[i][j]);
        }
        cout<<maxx<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值