E - Cows【凸包】

Your friend to the south is interested in building fences and turning plowshares into swords. In order to help with his overseas adventure, they are forced to save money on buying fence posts by using trees as fence posts wherever possible. Given the locations of some trees, you are to help farmers try to create the largest pasture that is possible. Not all the trees will need to be used.

However, because you will oversee the construction of the pasture yourself, all the farmers want to know is how many cows they can put in the pasture. It is well known that a cow needs at least 50 square metres of pasture to survive.

Input

The first line of input contains a single integer, n (1 ≤ n ≤ 10000), containing the number of trees that grow on the available land. The next n lines contain the integer coordinates of each tree given as two integers x and y separated by one space (where -1000 ≤ x, y ≤ 1000). The integer coordinates correlate exactly to distance in metres (e.g., the distance between coordinate (10; 11) and (11; 11) is one metre).

Output

You are to output a single integer value, the number of cows that can survive on the largest field you can construct using the available trees.

Sample Input

4
0 0
0 101
75 0
75 101

Sample Output

151

思路:先求凸包然后求面积。

code:

#include<iostream>
#include<cmath>
#include<algorithm>
#define MAX 100000
using namespace std;
typedef long long ll;
int top;
struct node{
	int x,y;
}d[MAX],s[MAX];
bool cmp1(node a,node b){
	if(a.x==b.x){
		return a.y<b.y;
	}
	return a.x<b.x;
}
bool cmp(node a,node b)
{
       double A=atan2((a.y-d[0].y),(a.x-d[0].x));
       double B=atan2((b.y-d[0].y),(b.x-d[0].x));
       if(A!=B) return A<B;
       else return a.x<b.x;
}
ll cross(node a,node b,node c)
{
	return (b.x-a.x)*(c.y-a.y)-(b.y-a.y)*(c.x-a.x);
}
void Convex_Hull()//求n个点凸包的算法
{
	int n;
	cin>>n;
	for(int i=0;i<n;i++)
	cin>>d[i].x>>d[i].y;
	sort(d,d+n,cmp1);
	s[0]=d[0];//找到最左下方的点,放进s
	sort(d+1,d+n,cmp);//按照倾角排从小到大,若相同按照距离排近的优先
	s[1]=d[1];//第一个点放进s
	top=1;//记录s的大小
	for(int i=2;i<n;){
		if(top && cross(s[top-1],d[i],s[top])>=0){//不满足条件,出s,理解见后面的图
			top--;
		}
		else{
			s[++top]=d[i++];
		}
	}
}
int main()
{
	Convex_Hull();
	int sum=0;
	for(int i=1;i<top;i++)
	{
		sum+=((s[i+1].x-s[0].x)*(s[i].y-s[0].y)-(s[i].x-s[0].x)*(s[i+1].y-s[0].y));
	}
	cout<<int(fabs(sum/2.0)/50)<<endl;
	return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值