PAT (Advanced Level)-1145 Hashing - Average Search Time

1145 Hashing - Average Search Time(25 分)

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table first. Then try to find another sequence of integer keys from the table and output the average search time (the number of comparisons made to find whether or not the key is in the table). The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive numbers: MSize, N, and M, which are the user-defined table size, the number of input numbers, and the number of keys to be found, respectively. All the three numbers are no more than 10​4​​. Then N distinct positive integers are given in the next line, followed by M positive integer keys in the next line. All the numbers in a line are separated by a space and are no more than 10​5​​.

Output Specification:

For each test case, in case it is impossible to insert some number, print in a line X cannot be inserted. where X is the input number. Finally print in a line the average search time for all the M keys, accurate up to 1 decimal place.

Sample Input:

4 5 4
10 6 4 15 11
11 4 15 2
 

Sample Output:

15 cannot be inserted.
2.8

不错的文章 :https://blog.csdn.net/qq_27093465/article/details/52348366

思路:

哈希函数:H(key) = key % TSize 

处理冲突方法:Hi = (H(key) + di) % TSize 

其中di∈ 1*1 , -1*1 , 2*2 , -2*2 , ··· k*k , -k*k (k < TSize)

每次查询基准为1步,d从0*0开始 

题目中提到 with positive increments only 只需要考虑正增量即可。

 

插入情况:如果k ∈[0, Tsize) 内都没有找到空位置,则插入失败。 
查询情况:执行和插入一样的操作,如果定位到的元素和当前元素相同,说明找到了;如果定位到的位置是空的,说明当前查询的元素不在哈希表中;如果k ∈[0, Tsize) 内都没有找到,说明该元素无法插入,将查询总数+1。

题目中提醒:如果给定的TSize是合数,则要变为>Tsize的最小素数。比如10000 ->10007

#include <iostream>
#include <vector>
#include <cmath>
using namespace std;


int msize, n, m;
vector<int>ef;
int isprime(int n)
{
	if (n < 2)return 0;
	for (int i = 2; i <= sqrt(n); ++i)
	{
		if (n%i == 0)
		{
			return 0;
		}
	}
	return 1;	
}
void insert(int key)
{
	int i = 0,h;
	while (i < msize)
	{
		h = (key % msize + i * i)%msize;
		if (ef[h] == 0)
		{
			ef[h] = key;
			return;
		}
		i++;
	}
	printf("%d cannot be inserted.\n",key);	
}

int search(int key)
{
	int  h,cnt = 0, i = 0;
	while (i < msize)
	{
		cnt++;
		h = (key % msize + i * i) % msize;
		if (ef[h] == 0||ef[h]==key)
		{
			return cnt;
		}
		i++;
	}
	return cnt + 1;
}

int main()
{
	int  i;
	double sum = 0;
	
	scanf("%d %d %d", &msize, &n, &m);
	while (!isprime(msize))msize++;
	ef=vector<int>(msize);
	for (i = 0; i < n; ++i)
	{
		int val;
		scanf("%d", &val);
		insert(val);
	}
	for (i = 0; i < m; ++i)
	{
		int val;
		scanf("%d", &val);
		sum+=search(val);

	}
	printf("%.1lf\n", sum / m);

}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值