PAT (Advanced Level)-1135 Is It A Red-Black Tree

1135 Is It A Red-Black Tree(30 分)

There is a kind of balanced binary search tree named red-black tree in the data structure. It has the following 5 properties:

  • (1) Every node is either red or black.
  • (2) The root is black.
  • (3) Every leaf (NULL) is black.
  • (4) If a node is red, then both its children are black.
  • For each node, all simple paths from the node to descendant leaves contain the same number of black nodes.

For example, the tree in Figure 1 is a red-black tree, while the ones in Figure 2 and 3 are not.

rbf1.jpgrbf2.jpgrbf3.jpg
Figure 1Figure 2Figure 3

For each given binary search tree, you are supposed to tell if it is a legal red-black tree.

Input Specification:

Each input file contains several test cases. The first line gives a positive integer K (≤30) which is the total number of cases. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the preorder traversal sequence of the tree. While all the keys in a tree are positive integers, we use negative signs to represent red nodes. All the numbers in a line are separated by a space. The sample input cases correspond to the trees shown in Figure 1, 2 and 3.

Output Specification:

For each test case, print in a line "Yes" if the given tree is a red-black tree, or "No" if not.

Sample Input:

3
9
7 -2 1 5 -4 -11 8 14 -15
9
11 -2 1 -7 5 -4 8 14 -15
8
10 -7 5 -6 8 15 -11 17

Sample Output:

Yes
No
No

红黑树是特殊的二叉搜索树 题目给出前序遍历 绝对值排序 从小到大 得到中序遍历 建树

用深搜判断满足条件 每一层dfs 先确定左子树的高度(根据扫到几个黑node确定),在确定右子树的高度,判断两者高度

这句话不好理解 For each node, all simple paths from the node to descendant leaves contain the same number of black nodes.

意思是 对于任意节点到叶子的路径中黑节点数量相等 这句话作为判断基准之一

另一个条件是 每一层dfs 扫到的节点的子节点是否满足颜色条件If a node is red, then both its children are black.

最后提交有数组越界访问的报错 开了动态数组建树

#include <iostream>
#include <algorithm>
using namespace std;


bool cmp(int a,int b)
{
	if (a < 0)a = -a;
	if (b < 0)b = -b;
	return a < b;

}
struct node
{
	int data;
	struct node*lchild, *rchild;
};
node* buildtree(int preL, int preR, int inoL, int inoR,int *pre,int *ino)
{
	if (preL > preR)return NULL;
	int e = pre[preL], idx = inoL;
	while (idx <= inoR && e != ino[idx])idx++;
	node *root = new node;
	root->data = e;
	root->lchild = root->rchild = NULL;

	int leftLength = idx - inoL;
	int leftPreEnd = preL + leftLength;
	root->lchild=buildtree(preL + 1, leftPreEnd, inoL, idx - 1,pre,ino);
	root->rchild=buildtree(leftPreEnd + 1, preR, idx + 1, inoR,pre,ino);

	return root;
}
bool istree = true;
int prenum = -1;
void dfs(node*root, int cnt)
{
	if (!istree)return;
	if (root == NULL)
	{
		if (prenum == -1)prenum = cnt;
		else if (prenum != cnt)istree = false;
		return;
	}
	if (root->data > 0)cnt++;
	else
	{
		if((root->lchild!=NULL)&&(root->lchild->data<0))istree = false;
		if((root->rchild!=NULL)&&(root->rchild->data<0))istree = false;
	}
	dfs(root->lchild, cnt);
	dfs(root->rchild, cnt);
}

int main()
{
	int k;
	cin >> k;
	while (k--)
	{
		int n;
		cin >> n;
		int *pre = new int[n];
		int *ino = new int[n];
		for (int i = 0; i < n; i++)
		{
			scanf("%d", &pre[i]);
			ino[i] = pre[i];
		}
		sort(ino, ino + n, cmp);
		node*root = buildtree(0, n - 1, 0, n - 1, pre,ino);
		if (root->data < 0)printf("No\n");
		else 
		{ 
			prenum = -1;
			istree = true;
			dfs(root, 0);			
			if (istree)printf("Yes\n");
			else printf("No\n");
		}
		
	}

}

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值