PAT (Advanced Level)-1136 A Delayed Palindrome

PAT (Basic Level)-1079延迟的回文数

1136 A Delayed Palindrome(20 分)

Consider a positive integer N written in standard notation with k+1 digits a​i​​ as a​k​​⋯a​1​​a​0​​ with 0≤a​i​​<10 for all i and a​k​​>0. Then N is palindromic if and only if a​i​​=a​k−i​​ for all i. Zero is written 0 and is also palindromic by definition.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. Such number is called a delayed palindrome. (Quoted from https://en.wikipedia.org/wiki/Palindromic_number )

Given any positive integer, you are supposed to find its paired palindromic number.

Input Specification:

Each input file contains one test case which gives a positive integer no more than 1000 digits.

Output Specification:

For each test case, print line by line the process of finding the palindromic number. The format of each line is the following:

A + B = C

where A is the original number, B is the reversed A, and C is their sum. A starts being the input number, and this process ends until C becomes a palindromic number -- in this case we print in the last line C is a palindromic number.; or if a palindromic number cannot be found in 10 iterations, print Not found in 10 iterations. instead.

Sample Input 1:

97152

Sample Output 1:

97152 + 25179 = 122331
122331 + 133221 = 255552
255552 is a palindromic number.

Sample Input 2:

196

Sample Output 2:

196 + 691 = 887
887 + 788 = 1675
1675 + 5761 = 7436
7436 + 6347 = 13783
13783 + 38731 = 52514
52514 + 41525 = 94039
94039 + 93049 = 187088
187088 + 880781 = 1067869
1067869 + 9687601 = 10755470
10755470 + 07455701 = 18211171
Not found in 10 iterations.

注意:输入的数比如说9 直接判断为回文 

#include <iostream> 
#include <string> 
#include <algorithm>
using namespace std;

string add(string a,string b)
{
	string res="";
	int cnt=0;
	for(int i=0;i<a.size();i++)
	{
		int sum=cnt+a[i]-'0'+b[i]-'0';
		res.insert(0,to_string(sum%10));
		if(sum>9)cnt=1;
		else cnt=0;
	}
	if(cnt)res.insert(0,"1");
	return res;
}
bool paljudge(string buf)
{
	for(int i=0;i<buf.size()/2;i++)
	{
		if(buf[i]!=buf[buf.size()-1-i])return false;
		
	}
	return true;
}
int main()
{
	string a;
	cin>>a;
	int t=10;
	if(paljudge(a))
	{
		cout<<a<<" is a palindromic number."<<endl;
		return 0;
	}
	while(t--)
	{
		string b(a);
		reverse(b.begin(),b.end());
		string buf=add(a, b);
		cout<<a<<" + "<<b<<" = "<<buf<<endl;
		if(paljudge(buf))
		{
			cout<<buf<<" is a palindromic number."<<endl;
			return 0;			
		}
		else
		{
			a="";
			a=buf;	
		}
	}
	cout<<"Not found in 10 iterations."<<endl;
		
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
DM-VIO是一种基于延迟边缘化的视觉惯性里程计(Visual-Inertial Odometry)算法。视觉惯性里程计是一种通过分析相机和惯性测量单元(IMU)的数据来估计相机在三维环境中的运动的技术。DM-VIO通过边缘化传感器测量历史来实现优化过程,以提高姿态和位置估计的准确性。 传统的VIO算法通常会使用非线性优化方法来进行估计,但是由于计算能力和传感器延迟的限制,实时性和鲁棒性方面存在一定的挑战。DM-VIO通过引入延迟边缘化的方法,将传感器测量历史进行边缘化处理,从而实现了良好的实时性能。 具体来说,DM-VIO首先对传感器数据进行预处理,包括惯性测量单元的时间戳校准和相机的畸变校正。然后通过非线性优化方法估计相机的位姿和速度。在优化过程中,DM-VIO使用延迟滑窗来处理传感器延迟问题,将最近的一段时间内的测量数据一起进行优化,并通过边缘化处理来移除旧的数据。 DM-VIO算法的优势在于它能够有效地处理传感器延迟,并且在保持良好的实时性能的同时提高了估计的准确性。通过考虑传感器测量历史,DM-VIO能够更好地捕捉相机的运动特性,并减少噪声和误差的影响。 总之,DM-VIO是一种基于延迟边缘化的视觉惯性里程计算法,通过处理传感器延迟和优化历史测量数据,它能够实现更好的实时性能和准确性,对于自主导航、增强现实等应用具有重要的意义。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值