hdu2119:Matrix

72 篇文章 0 订阅
30 篇文章 0 订阅

http://acm.hdu.edu.cn/showproblem.php?pid=2119

Problem Description

Give you a matrix(only contains 0 or 1),every time you can select a row or a column and delete all the '1' in this row or this column .

Your task is to give out the minimum times of deleting all the '1' in the matrix.

 

 

Input

There are several test cases.

The first line contains two integers n,m(1<=n,m<=100), n is the number of rows of the given matrix and m is the number of columns of the given matrix.
The next n lines describe the matrix:each line contains m integer, which may be either ‘1’ or ‘0’.

n=0 indicate the end of input.

 

 

Output

For each of the test cases, in the order given in the input, print one line containing the minimum times of deleting all the '1' in the matrix.

 

 

Sample Input

3 3

0 0 0

1 0 1

0 1 0

0

Sample Output

2

 

匈牙利算法,代码:

#include<stdio.h>
#include<string.h>
#define N 550
int a[N],line[N][N],book[N];
int k,m,n;
int find(int x)
{
	int i;
	for(i=1;i<=m;i++)
	{
		if(line[x][i]==1&&book[i]==0)
		{
			book[i]=1;
			if(a[i]==0||find(a[i]))
			{
				a[i]=x;
				return 1;
			}
		}
	}
	return 0;
}
int main()
{
	int sum,i,j;
	while(scanf("%d",&n),n!=0)
	{
		sum=0;
		scanf("%d",&m);
		memset(a,0,sizeof(a));
		memset(line,0,sizeof(line));
		memset(book,0,sizeof(book));
		for(i=1;i<=n;i++)
			for(j=1;j<=m;j++)
				scanf("%d",&line[i][j]);
		for(i=1;i<=n;i++)
		{
			memset(book,0,sizeof(book));
			if(find(i))
				sum++;
		}	
		printf("%d\n",sum);	
	}
	return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

张宜强

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值