hdu1083:Courses(二分图最大匹配)

72 篇文章 0 订阅
30 篇文章 0 订阅

http://acm.hdu.edu.cn/showproblem.php?pid=1083

Problem Description

Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:

. every student in the committee represents a different course (a student can represent a course if he/she visits that course)

. each course has a representative in the committee

Your program should read sets of data from a text file. The first line of the input file contains the number of the data sets. Each data set is presented in the following format:

P N
Count1 Student1 1 Student1 2 ... Student1 Count1
Count2 Student2 1 Student2 2 ... Student2 Count2
......
CountP StudentP 1 StudentP 2 ... StudentP CountP

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses . from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you'll find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.

There are no blank lines between consecutive sets of data. Input data are correct.

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

An example of program input and output:

 

 

Sample Input

2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1

Sample Output

YES
NO

题意分析:

有n门课程和m个同学,每个课程有多个同学学习,问能不能给每一个课程找一个课代表,每个人只能担任一个课程的课代表。

解题思路:

匈牙利匹配

#include <stdio.h>
#include <vector>
#include <string.h>
#define N 320
using namespace std;
int l[N], book[N], n, m;
vector<int>a[N];
int dfs(int u)
{
	int i, v, s;
	v=a[u].size();
	for(i=0; i<v; i++)
	{
		s=a[u][i];
		if(book[s]==0)
		{
			book[s]=1;
			if(l[s]==0 || dfs(l[s]))
			{
				l[s]=u;
				return 1;
			}
		}
	}
	return 0;
}
int main()
{
	int T, i, t, v, sum;
	scanf("%d", &T);
	while(T--)
	{
		memset(l, 0, sizeof(l));
		scanf("%d%d", &n, &m);
		for(i=1; i<=n; i++)
			a[i].clear();
		for(i=1; i<=n; i++)
		{
			scanf("%d", &t);
			while(t--)
			{
				scanf("%d", &v);
				a[i].push_back(v);
			}
		}
		sum=0;
		for(i=1; i<=n; i++)
		{
			memset(book, 0, sizeof(book));
			if(dfs(i))
				sum++;
		}
		if(sum==n)
			printf("YES\n");
		else
			printf("NO\n");
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

张宜强

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值