ZOJ 1586:QS Network(Prim)

http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=1586

Sunny Cup 2003 - Preliminary Round

April 20th, 12:00 - 17:00

Problem E: QS Network


In the planet w-503 of galaxy cgb, there is a kind of intelligent creature named QS. QScommunicate with each other via networks. If two QS want to get connected, they need to buy two network adapters (one for each QS) and a segment of network cable. Please be advised that ONE NETWORK ADAPTER CAN ONLY BE USED IN A SINGLE CONNECTION.(ie. if a QS want to setup four connections, it needs to buy four adapters). In the procedure of communication, a QS broadcasts its message to all the QS it is connected with, the group of QS who receive the message broadcast the message to all the QS they connected with, the procedure repeats until all the QS's have received the message.

A sample is shown below:

A sample QS network, and QS A want to send a message.

Step 1. QS A sends message to QS B and QS C;

Step 2. QS B sends message to QS A ; QS C sends message to QS A and QS D;

Step 3. the procedure terminates because all the QS received the message.

Each QS has its favorate brand of network adapters and always buys the brand in all of its connections. Also the distance between QS vary. Given the price of each QS's favorate brand of network adapters and the price of cable between each pair of QS, your task is to write a program to determine the minimum cost to setup a QS network.


Input

The 1st line of the input contains an integer t which indicates the number of data sets.

From the second line there are t data sets.

In a single data set,the 1st line contains an interger n which indicates the number of QS.

The 2nd line contains n integers, indicating the price of each QS's favorate network adapter.

In the 3rd line to the n+2th line contain a matrix indicating the price of cable between ecah pair of QS.

Constrains:

all the integers in the input are non-negative and not more than 1000.

 


Output

for each data set,output the minimum cost in a line. NO extra empty lines needed.


Sample Input

1
3
10 20 30
0 100 200
100 0 300
200 300 0


Sample Output

370

题意分析:

给出两点之间的修建费用和各个点的维修费用,如果要在两点之间建边,还需要对两个点进行维修, 求最小生成树。

解题思路:

把边的权值加上对应两点的权值,求最小生成树。

#include <stdio.h>
#include <string.h>
#define N 1020
int e[N][N], cost[N], dis[N];
bool book[N];
int main()
{
	int n, m, T, mini, count, u, inf=0x3f3f3f3f;
	scanf("%d", &T);
	while(T--)
	{
		scanf("%d", &n);
		for(int i=1; i<=n ;i++)
			scanf("%d", &cost[i]);
		for(int i=1; i<=n; i++)
			for(int j=1; j<=n; j++)	
			{
				scanf("%d", &e[i][j]);
				e[i][j]+=cost[i]+cost[j];
			}
		int sum=0;
		for(int i=1; i<=n ;i++)
			dis[i]=e[1][i];
		memset(book, false, sizeof(book));
		book[1]=true;
		count=1;
		while(count<n)
		{
			mini=inf;
			for(int j=1; j<=n; j++)
				if(book[j]==false && mini>dis[j])
				{
					mini=dis[j];
					u=j;
				}
			count++;
			sum+=dis[u];
			book[u]=true;
			for(int v=1; v<=n; v++)
			{
				if(book[v]==false && dis[v]>e[u][v])
					dis[v]=e[u][v];
			}
		}
		printf("%d\n", sum);	
	}
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

张宜强

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值