1015. Reversible Primes (20)(C++)

A reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line "Yes" if N is a reversible prime with radix D, or "No" if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

题目大意:判断某数及其在一特定进制下逆序是否为素数。

素数的判断有两种,一是直接判断,二建立素数表

#include <iostream>
#include <cmath>
using namespace std;
bool isprime(int x){
	if(x <= 1)
		return false;
	for(int i = 2; i <= sqrt(x); ++ i)
		if(x % i == 0)
			return false;
	return true;
}
int reversenum(int x, int radix){
	int ans = 0;
	while(x != 0){
		ans = ans * radix + (x % radix);
		x /= radix;
	}
	return ans;
}
int main(){
	int num, renum,radix;
	while(1){
		scanf("%d",&num);
		if(num < 0)
			return 0;
		scanf("%d",&radix);
		renum = reversenum(num, radix);
		if(isprime(renum) && isprime(num))
			printf("Yes\n");
		else
			printf("No\n");
	}
}

也可以建立素数表如下:

bool prime[1005];
prime[1]=true;prime[0]=true;
for(int i=2;i*i<1005;i++){
    for(int j=2;i*j<1005;j++)
        prime[i*j]=true;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值