1015. Reversible Primes (20)

102 篇文章 0 订阅
3 篇文章 0 订阅

1015. Reversible Primes (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line "Yes" if N is a reversible prime with radix D, or "No" if not.

Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No
一个数N(为十进制),判断他是否为质数
将N转换为D进制   翻转看其十进制的值是否为质数
如果都为质数Yes,否则No
例如:7 3  (7本身为质数;三进制表示21,那么翻转12,12的十进制值4,不是质数;综上结果No)
此题sqrt 求平方根函数,在头文件#include<math.h> 

评测结果

时间结果得分题目语言用时(ms)内存(kB)用户
7月27日 09:39答案正确201015C++ (g++ 4.7.2)1436datrilla

测试点

测试点结果用时(ms)内存(kB)得分/满分
0答案正确143612/12
1答案正确14362/2
2答案正确14364/4
3答案正确14362/2

#include<iostream>  
#include<math.h>
using namespace std;  
int reverseN(int p, int radix)
{
  int reverse = 0,i=0;
  while (p>0)
  {
    reverse = reverse*radix + p % radix;
    p /= radix;
  }
  return reverse;
}
bool PrImes(int p)
{
  int i ;
  if (p < 2)return false;
  for (i = 2; i <= sqrt(p); i++)
  {
    if (0 == p%i)return false;
  }
  return true;
}
int main()
{   
  int D, N; 
  while (cin >> N&&N>0)
  {  
    cin >> D;
    if (PrImes(N) && PrImes(reverseN(N, D)))cout << "Yes" << endl;
    else cout << "No" << endl;
  } 
  system("pause");  
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值