1060 Are They Equal(25 分)(C++)

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123×10​5​​ with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:

Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10​100​​, and that its total digit number is less than 100.

Output Specification:

For each test case, print in a line YES if the two numbers are treated equal, and then the number in the standard form 0.d[1]...d[N]*10^k (d[1]>0 unless the number is 0); or NO if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.

Sample Input 1:

3 12300 12358.9

Sample Output 1:

YES 0.123*10^5

Sample Input 2:

3 120 128

Sample Output 2:

NO 0.120*10^3 0.128*10^3

题目大意:理解起来并不麻烦,将一个数写成科学计算法,第一位为0,保留三位有效数字,判断两个数是否相同。

注意最后一个测试点,应该是原有的字符串长度都不够n。

#include <iostream>
#include <string>
using namespace std;
int n, a, b;
string s1, s2;
int get_num(string &s){
	int result = 0, flag = 1, i = 0, cnt = 0;
	while(s[i] == '0')
		++ i;
	if(s[i] == '.'){
		flag = -1;
		++ i;
	}
	bool flag_cnt = flag == -1 ? false : true;
	while(i < s.length() && isdigit(s[i])){
		if(flag == -1 && s[i] != '0'){
			flag = 0;
			flag_cnt = true;
		}
		result += flag;
		if(flag_cnt == true)
			s[cnt++] = s[i++];
		else
			++ i;
	}
	if(cnt == 0)
	  result = 0;
	if(i < s.length() && s[i] == '.')
		++ i;
	while(cnt < n){
		if(cnt == s.length())
			s += '0';
		else if(i == s.length())
			s[cnt++] = '0';
		else
			s[cnt++] = s[i++];
	}
	s.resize(n);
	return result;
}
int main(){
	cin >> n >> s1 >> s2;
	a = get_num(s1);
	b = get_num(s2);
	if(a == b && s1 == s2)
		printf("YES");
	else
		printf("NO 0.%s*10^%d", s1.c_str(),a);
	printf(" 0.%s*10^%d",s2.c_str(),b);
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值