1154 Vertex Coloring (25 分)(C++)

proper vertex coloring is a labeling of the graph's vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most k colors is called a (proper) k-coloring.

Now you are supposed to tell if a given coloring is a proper k-coloring.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10​4​​), being the total numbers of vertices and edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of colorings you are supposed to check. Then K lines follow, each contains N colors which are represented by non-negative integers in the range of int. The i-th color is the color of the i-th vertex.

Output Specification:

For each coloring, print in a line k-coloring if it is a proper k-coloring for some positive k, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
4
0 1 0 1 4 1 0 1 3 0
0 1 0 1 4 1 0 1 0 0
8 1 0 1 4 1 0 5 3 0
1 2 3 4 5 6 7 8 8 9

Sample Output:

4-coloring
No
6-coloring
No

解题思路:本题虽然是无向图,但是在存储过程中,只需要存储一条边(存储较大序号到较小序号的一边),因为我们在涂色过程中,需要找该节点的已涂色的邻节点(肯定比它小,比它的节点还没涂色)

#include <iostream>
#include <vector>
#include <set>
using namespace std;
int main(){
    int n, m, k;
    cin>>n>>m;
    std::vector<int> graph[n];
    for(int i = 0; i < m; i++){
        int a, b;
        scanf("%d %d",&a,&b);
        if(a > b)
            swap(a,b);
        graph[b].push_back(a);
    }
    cin>>k;
    for(int j = 0; j < k; j++){
        std::vector<int> color(n);
        set<int>ans;
        bool flag = true;
        for(int i = 0; i < n; i++){
            scanf("%d", &color[i]);
            ans.insert(color[i]);
            for(int u = 0; u < graph[i].size(); u++)
                if(color[graph[i][u]] == color[i]){
                    flag = false;
                    break;
                }
        }
        if(flag == false)
            printf("No\n");
        else
            printf("%d-coloring\n",ans.size());
    }
}

加一个DFS版的(。-ω-)zzz,感谢某个小伙伴的建议

#include <iostream>
#include <vector>
#include <set>
using namespace std;
int n, m, k;
vector<int>graph[10005], color(10005);
bool visit[10005], flag;
void dfs(int index){
	if(!flag)
		return;
	visit[index] = true;
	for(int i = 0; i < graph[index].size(); ++ i){
		if(color[index] == color[graph[index][i]]){
			flag = false;
			break;
		}
		if(visit[graph[index][i]] == false)
			dfs(graph[index][i]);
	}
		
}
int main(){
	scanf("%d %d", &n, &m);
	for(int i = 0; i < m; ++ i){
		int a, b;
		scanf("%d %d", &a, &b);
		graph[a].push_back(b);
	}
	scanf("%d", &k);
	for(int i = 0; i < k; ++ i){
		set<int>s;
		for(int j = 0; j < n; ++ j){
			scanf("%d", &color[j]);
			s.insert(color[j]); 
		}
		fill(visit, visit + 10005, false);
		flag = true;
		for(int j = 0; j < n; ++ j)
			if(visit[j] == false)
				dfs(j);
		if(flag)
			printf("%d-coloring\n", s.size());
		else
			printf("No\n");
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值