Billboard (线段树---详解)

At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information. 

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard. 

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi. 

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one. 

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university). 

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
InputThere are multiple cases (no more than 40 cases). 

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements. 

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.OutputFor each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.Sample Input
3 5 5
2
4
3
3
3
Sample Output
1
2
1
3
-1

题意:

要在h*w宣传栏上贴公告,每条公告的高度都是为1的,而且每条公告都要尽量贴最上面最靠左边的,给你一系列的公告的长度,问它们能不能贴上。

1 ~ h分 , 每层的父节点记录的是剩余的最大空间 , 初始值每个节点都是w , 它的宽度 , 每帖一个广告 , 相应的减去他的宽度 , 再更新一下 , 周而复始。

下面代码:

#include <stdio.h>
#include <iostream>
using namespace std;

#define lson l , m , rt << 1
#define rson m+1 , r ,rt << 1|1

const int maxn = 222222;
int Max[maxn << 2];
int h , w , n;

void PushUp(int rt)
{
	Max[rt] = max(Max[rt<<1] ,Max[rt <<1|1]);
 } 
void Build(int l , int r , int rt)
{
	
	if(l == r)
	{
		Max[rt] = w;
		return;
	}
	int m = (l+r) >> 1;
	Build(lson);
	Build(rson);
	PushUp(rt);
}
int query(int x , int l , int r , int rt)
{
	if(l == r)
	{
		Max[rt] -= x;
		return l;//注意!!!返回左值!!!! 
	}
	int m = (l+r)>>1;
	int ret = (Max[rt<<1] >= x) ? query(x,lson) : query(x ,rson);
	PushUp(rt);
	return ret;
}
int main()
{
	int x;
	while(~scanf("%d %d %d" , &h , &w ,&n))
	{
		if(h >= n)//原因是h的范围到1e9而n是200000 ,如果 h > n 的话 , 大于 n 的部分就没用了  
		{
			h = n;
		}
		Build(1 , h , 1);
		 while(n--)
		 {
		 	scanf("%d" , &x);
		 	if(Max[1] < x)
		 	{
		 		printf("-1\n");
			 }
			 else
			 {
			 	printf("%d\n" , query(x , 1 ,h ,1));
			 }
		 }
	}
	
	return 0;
 } 



  • 1
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值