【HDU - 2795 Billboard】 线段树

E - Billboard

At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information. 

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard. 

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi. 

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one. 

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university). 

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
Input
There are multiple cases (no more than 40 cases). 

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements. 

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
Sample Input
3 5 5
2
4
3
3
3
Sample Output
1
2
1
3
-1

 
  
题意:给出一个高h宽w的公告栏,现有n个公告需要投放到公告栏上,每个公告的高度都为1。投放公告时,按照从上到下的规则投放,输出每个公告所在的位置高度,若公告无法投放到公告栏上,则输出-1。
 
  
分析:一道变形的线段树。正常建树,每个节点初始化为w,节点的值为其所有子树值中的最大值(即这几行中能放入广告的最大宽度)。然后每次判断并更新树。
 
  
代码如下:
#include <set>
#include <map>
#include <queue>
#include <cmath>
#include <vector>
#include <cctype>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#define MX 200005
#define lson l, m, rt << 1
#define rson m+1, r, rt << 1|1
#define mod 835672545
#define INF 0x3f3f3f3f
#define LL long long
using namespace std;
int h, w, n;
struct node {
    int w, l, r;
} tree[MX<<2];
void build(int l, int r, int rt, int w) {
    tree[rt].l = l;
    tree[rt].r = r;
    tree[rt].w = w;
    if(tree[rt].l == tree[rt].r) {
        return ;
    }
    int m = (tree[rt].l + tree[rt].r) / 2;
    build(lson, w);
    build(rson, w);
}
void pushup(int rt) {
    tree[rt].w = max(tree[rt<<1].w, tree[rt<<1|1].w);
}
void update(int rt, int w) {
    if(tree[rt].l == tree[rt].r) {
        tree[rt].w -= w;
        printf("%d\n", tree[rt].l);
        return ;
    }
    if(w <= tree[rt<<1].w)  update(rt << 1, w);
    else update(rt << 1|1, w);
    pushup(rt);
}
int main() {
    while(~scanf("%d%d%d", &h, &w, &n)) {
        if(h > n)   h = n;          //h > n 时所有公告都可放入
        build(1, h, 1, w);
        int temp;
        for(int i = 0; i < n; i++) {
            scanf("%d", &temp);
            if(temp > tree[1].w)    printf("-1\n");
            else update(1, temp);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值