Tell me the area(计算几何--求两圆相交面积)

Description

    There are two circles in the plane (shown in the below picture), there is a common area between the two circles. The problem is easy that you just tell me the common area.

 

Input

There are many cases. In each case, there are two lines. Each line has three numbers: the coordinates (X and Y) of the centre of a circle, and the radius of the circle.
 

Output

For each case, you just print the common area which is rounded to three digits after the decimal point. For more details, just look at the sample.
 

Sample Input

 
   
0 0 22 2 1
 

Sample Output

 
   

0.108



acos()函数调用时括号内是弧度
弧度=角度*π/180
 

#include <stdio.h>
#include<math.h>
#define PI acos(-1.0)   //PI就是π
int main()
{
    double x1,y1,x2,y2,r1,r2,s,ans,z1,z2,s1,s2,m1,m2;
    while(scanf("%lf%lf%lf%lf%lf%lf",&x1,&y1,&r1,&x2,&y2,&r2)!=EOF)
    {
        s=sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));   //求两点之间的距离
        if(s>=r1+r2||r1==0||r2==0)      //相离的情况
            printf("0.000\n");
        else if(s<=fabs(r1-r2)&&s>=0)    //相切的情况 面积是小圆
        {
            if(r1<r2)
                ans=PI*r1*r1;
            else
                ans=PI*r2*r2;
            printf("%.3lf\n",ans);
        }
        else                             //相交的情况
        {
            z1=acos((r1*r1+s*s-r2*r2)/(2*r1*s));      //这里是余弦定理(对r1 r2 s这个三角形)z1是扇形圆心角一半的弧度
            z2=acos((r2*r2+s*s-r1*r1)/(2*r2*s));    //同上
            s1=z1*r1*r1;      //这里是求扇形的面积 面积公式s=n(圆心角)*π*r*r/360 
            s2=z2*r2*r2;     //同上
            m1=r1*r1*sin(z1)*cos(z1);   //这里是求三角形面积 s=1/2*a*b*sin c
            m2=r2*r2*sin(z2)*cos(z2);   //同上
            ans=s1+s2-m1-m2;       
            printf("%.3lf\n",ans);
        }
    }

    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值