LightOJ 1008 Fibsieve`s Fantabulous Birthday(规律)

Fibsieve`s Fantabulous Birthday

Fibsieve had a fantabulous (yes, it’s an actual word) birthday party this year. He had so many gifts that he was actually thinking of not having a party next year.

Among these gifts there was an N x N glass chessboard that had a light in each of its cells. When the board was turned on a distinct cell would light up every second, and then go dark.

The cells would light up in the sequence shown in the diagram. Each cell is marked with the second in which it would light up.

在这里插入图片描述

(The numbers in the grids stand for the time when the corresponding cell lights up)

In the first second the light at cell (1, 1) would be on. And in the 5th second the cell (3, 1) would be on. Now, Fibsieve is trying to predict which cell will light up at a certain time (given in seconds). Assume that N is large enough.

Input
Input starts with an integer T (≤ 200), denoting the number of test cases.

Each case will contain an integer S (1 ≤ S ≤ 1015) which stands for the time.

Output
For each case you have to print the case number and two numbers (x, y), the column and the row number.

Sample Input

3
8
20
25

Sample Output

Case 1: 2 3
Case 2: 5 4
Case 3: 1 5

题意
给出一个规律表示灯亮的规律,给出一个时间 s s s找到该时间亮的灯的坐标

题解
找规律, s s s的范围很大明显打表,暴力啥的都不可能,明显就是找规律
明显我们只看对角线
在这里插入图片描述
发现对角线的数值等于 x 2 − x + 1 x^2-x+1 x2x+1也可以说是 x ( x − 1 ) + 1 x(x-1)+1 x(x1)+1
因此我们就可以对给出的 s s s开方,来判断其大概在哪行哪列

代码

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <queue>
#include <cmath>
#include <string>
#include <cstring>
#include <map>
#include <set>
#include <cmath>

using namespace std;
#define me(x,y) memset(x,y,sizeof x)
#define MIN(x,y) x < y ? x : y
#define MAX(x,y) x > y ? x : y
typedef long long ll;
const int maxn = 1e5;
const double INF = 0x3f3f3f3f;
const int MOD = 1e9+7;
const int eps = 1e-8;


int main(){
    
    int t;
    cin>>t;
    for(int ca = 1; ca <= t; ++ca){
        ll n;
        cin>>n;
        printf("Case %d: ",ca);
        if(n == 1){
            printf("1 1\n");
            continue;
        }
        ll a = (ll)sqrt(n);
        if(a*a == n){
            if(a&1)printf("1 %lld\n",a);
            else printf("%lld 1\n",a);
        }
        else{
            a++;
            ll k = a*a-a+1;
            if(a&1)printf("%lld %lld\n",n >= k ? a-(n-k):a,n >= k ? a : a-(k-n));
            else printf("%lld %lld\n",n >= k ? a:a-(k-n),n >= k ? a-(n-k) : a);
        }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值