LightOJ 1038 Race to 1 Again(概率DP)

Race to 1 Again

Rimi learned a new thing about integers, which is - any positive integer greater than 1 can be divided by its divisors. So, he is now playing with this property. He selects a number N. And he calls this D.

In each turn he randomly chooses a divisor of D (1 to D). Then he divides D by the number to obtain new D. He repeats this procedure until D becomes 1. What is the expected number of moves required for N to become 1.

Input
Input starts with an integer T (≤ 10000), denoting the number of test cases.
Each case begins with an integer N (1 ≤ N ≤ 105).

Output
For each case of input you have to print the case number and the expected value. Errors less than 10-6 will be ignored.

Sample Input

3
1
2
50

Sample Output

Case 1: 0
Case 2: 2.00
Case 3: 3.0333333333

题意
对于一个数 n n n,求把它变回1,所需要的除的次数的期望

题解
概率DP。
d p [ i ] dp[i] dp[i]表示需要次数为 i i i的期望
状态转移方程:
d p [ i ] = ∑ d ∣ i d p [ d ] n u m [ i ] + 1 d p [ i ] n u m [ i ] = ∑ d ∣ i d p [ d ] + n u m [ i ] d p [ i ] ( n u m [ i ] − 1 ) = ∑ d ∣ i , d = ̸ i d p [ d ] + n u m [ i ] d p [ i ] = ∑ d ∣ i , d = ̸ i d p [ d ] + n u m [ i ] n u m [ i ] − 1 \begin{aligned} dp[i]&=\cfrac{\sum_{d|i}{dp[d]}}{num[i]}+1\\ dp[i]num[i]&=\sum_{d|i}dp[d]+num[i]\\ dp[i](num[i]-1)&=\sum_{d|i,d=\not i}dp[d]+num[i]\\ dp[i]&=\cfrac{\sum_{d|i,d=\not i}dp[d]+num[i]}{num[i]-1} \end{aligned} dp[i]dp[i]num[i]dp[i](num[i]1)dp[i]=num[i]didp[d]+1=didp[d]+num[i]=di,d≠idp[d]+num[i]=num[i]1di,d≠idp[d]+num[i]
其中 d ∣ i d|i di表示 d d d i i i的因子, n u m [ i ] num[i] num[i]表示 i i i的因子个数

求解时,对每个 i ( i > 1 ) i(i>1) i(i>1)都通过公式求出其 d p [ i ] dp[i] dp[i],并对 n u m [ i ] + 1 num[i]+1 num[i]+1 i i i本身也是因子),然后对 i i i的倍数 j j j都进行 d p [ j ] + = d p [ i ] dp[j]+=dp[i] dp[j]+=dp[i]并且 n u m [ j ] + 1 num[j]+1 num[j]+1,
代码

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <queue>
#include <cmath>
#include <string>
#include <cstring>
#include <map>
#include <set>
#include <cmath>

using namespace std;
#define me(x,y) memset(x,y,sizeof x)
#define MIN(x,y) x < y ? x : y
#define MAX(x,y) x > y ? x : y
typedef long long ll;
typedef unsigned long long ull;
const int maxn = 1e5;
const ll INF = 0x3f3f3f3f;
const int MOD = 998244353;
const double eps = 1e-06;

double dp[maxn+10];
int num[maxn+10];
void get_dp(){
    me(dp,0);
    me(num,0);
    dp[1] = 0;
    for(int i = 1; i <= maxn; ++i){
        num[i]++;
        if(i>1)dp[i] = (dp[i]+num[i])/(num[i]-1);
        for(int j = i*2; j <= maxn; j += i){
            dp[j] += dp[i];
            num[j]++;
        }
    }
}

int main(){
    int t;
    get_dp();
    cin>>t;
    for(int ca = 1; ca <= t; ca++){
        int n;
        cin>>n;
        printf("Case %d: %lf\n",ca,dp[n]);
    }
    return 0;
}


/*


*/
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值