2019-3 To Fill or Not to Fill (30 分)

With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive numbers: Cmax​ (≤ 100), the maximum capacity of the tank; D (≤30000), the distance between Hangzhou and the destination city; Davg​ (≤20), the average distance per unit gas that the car can run; and N (≤ 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: Pi​, the unit gas price, and Di​ (≤D), the distance between this station and Hangzhou, for i=1,⋯,N. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print The maximum travel distance = X where X is the maximum possible distance the car can run, accurate up to 2 decimal places.

Sample Input 1:

50 1300 12 8
6.00 1250
7.00 600
7.00 150
7.10 0
7.20 200
7.50 400
7.30 1000
6.85 300

Sample Output 1:

749.17

Sample Input 2:

50 1300 12 2
7.10 0
7.00 600

Sample Output 2:

The maximum travel distance = 1200.00
#include <iostream>
#include <iomanip>
#include <algorithm>
using namespace std;

int Cmax,D,Davg,N;
struct station{
    float price;
    float loc;
}s[500];


bool cmp(station a,station b)
{
	return a.loc < b.loc;
}

int main(){
    cin >> Cmax >> D >> Davg >> N;
    float onceDistance = Cmax*Davg; //装满油能走的最远距离
    float maxDistance = 0; //已走距离
    float minPrice = 0; //走到目的地最便宜花费
    int sta = 0; //当前站点
    float currentOil = 0; //油箱内还剩多少油
    
    if(Cmax > 100 && D > 30000 && Davg > 20 && N > 500){
        return 0;
    }
    
    for(int i=0; i<N; i++){
        cin >> s[i].price >> s[i].loc;
    }
    sort(s,s+N,cmp);
    if(s[0].loc!=0){  //起始点无法加油
        cout << "The maximum travel distance = 0.00";
        return 0; 
    }
    else{
        while(sta < N-1){  //还有加油站
            if(s[sta+1].loc-s[sta].loc > onceDistance){  //加满油无法到达下一个加油站
                maxDistance = s[sta].loc + onceDistance;
                cout << setiosflags(ios::fixed) << setprecision(2);
                cout << "The maximum travel distance = " << maxDistance;
                return 0;
            }
            else{
                int next = sta;
                for(int t=sta; s[t].loc - s[sta].loc <= onceDistance & t < N; t++){
                    if(s[t].price < s[next].price){  //寻找范围内第一个比当前加油站更便宜的加油站
                        next = t;
                        minPrice += (s[next].loc - s[sta].loc - currentOil*Davg)/Davg*s[sta].price;  //在当前加油站加够到更便宜站点的油
                        currentOil = (s[next].loc - s[sta].loc)/Davg;
                        break;
                    }
                }
                if(next == sta && D - s[sta].loc > onceDistance){  //范围内没有找到更便宜的,继而开始找最便宜的
                    next = sta+1;
                    for(int t=sta+1; s[t].loc - s[sta].loc <= onceDistance & t < N; t++){
                        if(s[t].price <= s[next].price){
                            next = t;
                        }
                    }
                    minPrice += (Cmax - currentOil)*s[sta].price;  //在当前加油站加满油
                    currentOil = Cmax;
                }
                if(next == sta && D - s[sta].loc <= onceDistance){  //范围内没有找到更便宜的,且可以直接到达目的地
                    minPrice += (D - s[sta].loc - currentOil*Davg)/Davg*s[sta].price;  //在当前加油站加够到目的地的油
                    cout << setiosflags(ios::fixed) << setprecision(2);
                    cout << minPrice;
                    return 0;
                }
                currentOil -= (s[next].loc - s[sta].loc)/Davg;
                maxDistance = s[next].loc;
                sta = next;  //行进到下一个加油站
            }
        }
        if( D - s[sta].loc > 0 && D - s[sta].loc <= onceDistance && sta == N-1){  //最后一个加油站可以到达目的地
            minPrice += (D - s[sta].loc - currentOil*Davg)/Davg*s[sta].price;
            cout << setiosflags(ios::fixed) << setprecision(2);
            cout << minPrice;
            return 0;
        }
        if( D - s[sta].loc > onceDistance && sta == N-1){  //最后一个加油站到不了目的地
            maxDistance = s[sta].loc + onceDistance;
            cout << setiosflags(ios::fixed) << setprecision(2);
            cout << "The maximum travel distance = " << maxDistance;
            return 0;
        }
        if( D - s[sta].loc == 0 && sta == N-1){  //最后一个加油站刚好在目的地
            cout << setiosflags(ios::fixed) << setprecision(2);
            cout << minPrice;
            return 0;
         }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值