Ultra-QuickSort(归并排序求逆序对)

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 

9 1 0 5 4 ,


Ultra-QuickSort produces the output 

0 1 4 5 9 .


Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

题意:给了n个数,这n个数只能两两交换相邻的两个数,求:要得到升序的序列,最少需要多少次交换?

思路:主要还是求逆序对的个数,又因为每个数太大,因此不能用树状数组,所以我们选择使用 归并排序来求逆序对的个数。裸题,直接上代码吧!

代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
#define ll long long
#define N  500010
using namespace std;
ll a[N],b[N];
ll sum;
void work(int l,int mid,int r)
{
    int i=l,j=mid+1,k=l;
    while(i<=mid||j<=r)
    {
        if(i>mid)
            b[k++]=a[j++];
        else if(j>r)
            b[k++]=a[i++];
        else
        {
            if(a[i]<a[j])
                b[k++]=a[i++];
            else
            {
                sum+=mid-i+1;
                b[k++]=a[j++];
            }
        }
    }
    for(int i=l;i<=r;i++)
        a[i]=b[i];
}
void mysort(int l,int r)
{
    if(l<r)
    {
        int mid=(l+r)>>1;
        mysort(l,mid);
        mysort(mid+1,r);
        work(l,mid,r);
    }
}
int main()
{
    int n;
    while(~scanf("%d",&n)&&n)
    {
        sum=0;
        for(int i=1;i<=n;i++)
            scanf("%lld",&a[i]);
        mysort(1,n);
        printf("%lld\n",sum);
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值