Aggressive cows

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). 

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C 

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS: 

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3. 

Huge input data,scanf is recommended.

Source

USACO 2005 February Gold

#include<stdio.h>
#include<iostream>
#include<algorithm>
using namespace std;
bool check(int d);
int N,C;
int a[100002];
int main()
{
    scanf("%d %d",&N,&C);
    for(int i = 0;i < N;i++){
        scanf("%d",&a[i]);
    }
    sort(a,a+N);
    int L = 1;
    int R = (a[N-1] - a[0])/(C - 1);
    while(L <= R){
        int mid = (L + R)/2;
        if(check(mid)){
            L = mid + 1;
        }
        else
            R = mid - 1;
    }
    printf("%d",R);
}
bool check(int d){ //第一头牛放在a[0]位置
    int p = 0;    
    int cow = 1;
    for(int i = 1;i < N;i++){
        if(a[i] >= a[p] + d){ //判断如以d为间隔,能放下几头牛(后一个牛棚与前一个放入牛的牛棚之间的距离为d)
            cow++;
            p = i;
        }
    }
    if(cow >= C) //如果以d为间放入的牛,比牛的总数多。则间隔d有效。
        return true;
    else
        return false;
}

最小最大值(小于p,小标最大的数)。

第一头牛放在a[0]位置,剩下的C -1头牛,最大间距为 ( a[n-1] - a[0] ) / (c - 1 );

对L = 1 R = 对大间距,进行最小最大求值。

输出R根据模拟得出

第一次:L = 0  R = 4 mid = 2;

第二次:L = 3  R=4 mid = 3;

第三次:L = 4  R = 4 mid = 4 (d不符合要求)

第四次:L = 4  R=3 循环结束

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值