1110 Complete Binary Tree (25分)

 

1110 Complete Binary Tree (25分)

Given a tree, you are supposed to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤20) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each case, print in one line YES and the index of the last node if the tree is a complete binary tree, or NO and the index of the root if not. There must be exactly one space separating the word and the number.

Sample Input 1:

9
7 8
- -
- -
- -
0 1
2 3
4 5
- -
- -

Sample Output 1:

YES 8

Sample Input 2:

8
- -
4 5
0 6
- -
2 3
- 7
- -
- -

Sample Output 2:

NO 1
#include <iostream>
#include <algorithm>
#include<vector>
#include<map>
#include<string>
#include<cmath>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<set>
#include<unordered_map>
#include<queue>
#include<climits>
#include<stack>
using namespace std;
const int maxn= 10000+10;

struct Node{
	int id,l,r,index,lever;
		
}a[maxn],b[maxn],c[maxn];


int n,k=0;

//bool cmp(Node x,Node y){
//	if(x.lever!=y.lever) return x.lever<y.lever;
//	return x.index>y.index;
//	
//}

int max_id=-1,maxroot;
void inorder(int root ,int index,int lever){
	if(index>max_id){
		max_id=index;
		maxroot=root;
	}
	if(a[root].l!=-1) inorder(a[root].l,index*2,lever+1);
	//c[cnt++]={a[root],a[root].l,a[root].r,index,lever};	
	if(a[root].r!=-1) inorder(a[root].r,index*2+1,lever+1);
	
}

int main(){
	cin>>n;
	int have[maxn]={0};
	int root=0;
	for(int i=0;i<n;i++){
		a[i].id=i;
		string l,r;
		cin>>l>>r;		
		if(l=="-"){
			a[i].l=-1;		
		}else{
			a[i].l=stoi(l);	
			have[stoi(l)]=1;		
		}
		if(r=="-"){
			a[i].r=-1;		
		}else{
			a[i].r=stoi(r);	
			have[stoi(r)]=1;		
		}
	}
	while(have[root]==1) root++;
	inorder(root,1,0);
//	for(int i=0;i<n;i++){
//		b[i]=c[i];	
//	}
//		sort(c,c+n,cmp); 
//	for(int i=0;i<n;i++) {
//		if(i!=0) cout<<" ";
//		cout<<c[i].id;
//	} 
//	cout<<endl;
//
//	for(int i=0;i<n;i++) {
//		if(i!=0) cout<<" ";
//		cout<<b[i].id;
//	} 
	if(max_id==n){
		cout<<"YES "<<maxroot;
		
	}else {
		cout<<"NO "<<root;
	}
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值