【PAT】1046 Shortest Distance (20分) (模拟)

题目:

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3,10​5​​]), followed by N integer distances D​1​​ D​2​​ ⋯ D​N​​, where D​i​​ is the distance between the i-th and the (i+1)-st exits, and D​N​​ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10​4​​), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10​7​​.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7

题目大意:一个环形高速路上有N个出口(exits)找出每个出口之间的最短距离;  

解题思路:将从每个出口到 假想原点 的距离保存在一个可变数组中,由于是环状的,那么1->2的最短距离可能是顺时针也可能是逆时针,所以用sum保存整个环的距离,在顺时针和逆时针中取一个最小的距离即可。查询距离时,为了防止出现负数,要判断输入的大小,必要时交换。且由于可变数组是从0~n-1的,输入的数字也要纷纷-1,以对应可变数组的距离。

代码:

#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
int main(){
  
  int n,m,temp,sum=0;
  cin>>n;
  vector<int> v(n+1);
  v[0]=0;//0-1的距离为0;
  for(int i=1;i<=n;i++){
    cin>>temp;
    v[i]=v[i-1]+temp;
    sum+=temp;
  }
  cin>>m;
  int k,h;
  for(int i=0;i<m;i++){
    cin>>k>>h;
    if(k>h){
      swap(k,h);
    }
      h--;k--;
    
    cout<<(min(v[h]-v[k],sum-(v[h]-v[k])))<<endl;
  }return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值