1050 String Subtraction (20 分)(Hash散列,字符串,getline)

92 篇文章 0 订阅

Given two strings S

1

and S

2

, S=S

1

S

2

is defined to be the remaining string after taking all the characters in S

2

from S

1

. Your task is simply to calculate S

1

S

2

for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S

1

and S

2

, respectively. The string lengths of both strings are no more than 10

4

. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S

1

S

2

in one line.

Sample Input:

They are students.

aeiou

Sample Output:

Thy r stdnts.

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
#include <set>
#include <string>
#include <cctype>
#include <string.h>
#include <cstdio>
using namespace std;
char s1[20000],s2[20000];
int main(){
    cin.getline(s1,20000);
    cin.getline(s2,20000);
    int len1=strlen(s1),len2=strlen(s2);
    bool flag[256]={false};
    for(int i=0;i<len2;i++)
        flag[s2[i]]=true;
    for(int i=0;i<len1;i++){
        if(!flag[s1[i]])
            printf("%c",s1[i]);
    }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

小火汁猛猛

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值