PAT甲 1050 String Subtraction (20point(s)) & codeup 问题 D: String Subtraction (20)

题目链接:PAT A 1050
Given two strings S​1​​ and S​2​​, S=S​1​​−S​2​​ is defined to be the remaining string after taking all the characters in S​2​​ from S​1​​. Your task is simply to calculate S​1​​−S​2​​ for any given strings. However, it might not be that simple to do it fast.

Sample Input:

They are students.
aeiou

Sample Output:

Thy r stdnts.

Hash:

#include<bits/stdc++.h>
using namespace std;
int main()
{
    string ss, sub;
    int H[200] = {0};
    while(getline(cin, ss))
    {
        getline(cin, sub);
        for(int i = 0; i < sub.size(); ++i)
            H[sub[i]] = 1;
        for(int i = 0; i < ss.size(); ++i)
            if(H[ss[i]] == 0) cout << ss[i];
        cout << endl;
    }
    return 0;
}

String:

#include<bits/stdc++.h>
using namespace std;
int main()
{
    string ss, sub;
    while(getline(cin, ss))
    {
        getline(cin, sub);
        for(int i = 0; i < ss.size(); ++i)
            if(sub.find(ss[i]) == string::npos)
                cout << ss[i];
        cout << endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值