PAT B1010 一元多项式求导

PAT B1010 一元多项式求导

在这里插入图片描述### 输入样例:

3 4 -5 2 6 1 -2 0

输出样例:

12 3 -10 1 6 0
  • code1
#include <stdio.h>
#include <algorithm>
using namespace std;
const int maxn = 1010;
const int INF = 0x3fffffff;
int main(){
	int c, e;
	int a[maxn];
	int ans[maxn];
	fill(a, a+maxn, INF);
	fill(ans, ans+maxn, INF);
	while(scanf("%d %d", &c, &e) != EOF){
		a[e] = c;
	}
	int cnt = 0;
	for(int i = 1; i < maxn; ++i){
		if(a[i] != INF){
			cnt++;	//==求导后的项数 
			ans[i-1] = a[i]*i;
		}
	}
	if(cnt == 0) printf("0 0");	//判特!!! 
	else{	
		for(int i = maxn-1; i >= 0; --i){
			if(ans[i] != INF){
				printf("%d %d", ans[i], i);
				if(cnt > 1){
					printf(" ");
					cnt--;
				}
			}
		}
	}
} 
  • T2 code:
#include <bits/stdc++.h>
using namespace std;
const int maxn = 1010;
int poly[maxn];
int main(){
	int ex, co, cnt = 0;
	while(scanf("%d %d", &co, &ex) != EOF){
		poly[ex] = co;
	}
	for(int i = 1; i < maxn; ++i){
		if(poly[i]) cnt++;
 		poly[i-1] = i * poly[i];
	}
	if(!cnt) printf("0 0");
	else{
		for(int i = maxn; i >= 0; --i){
			if(poly[i]){
				printf("%d %d", poly[i], i);
				if(--cnt) printf(" ");
			} 
		}	
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值